aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 00:36:26 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:01 +0800
commit08b34ca0fc915ea440b069ec8cd18c142a5a5523 (patch)
tree6c05372de925f52696df0fb411e55676ae842b73 /gnu
parentf147673663c0db0e2c1e984f66573fc95691edc4 (diff)
downloadguix-08b34ca0fc915ea440b069ec8cd18c142a5a5523.tar.gz
guix-08b34ca0fc915ea440b069ec8cd18c142a5a5523.zip
gnu: solid: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (solid): Update to 6.3.0. [arguments]: Stop replace check phase. [inputs]: Remove qtbase-5 and qtdeclarative-5; add util-linux:lib, libxkbcommon, vulkan-headers, qtbase, and qtdeclarative. [native-inputs]: Remove qttools-5; add qttools. Change-Id: I99888a11c468efa0f1e898a1c4faa37ab1b078d7
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 2438512722..b9f1c24fbb 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1460,7 +1460,7 @@ feel.")
(define-public solid
(package
(name "solid")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1469,20 +1469,16 @@ feel.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1slxlj5jhp8g745l328932934633nl81sq3n8fd73h655hymsk4s"))))
+ "1nckgnr2834ppjjm3nq5xcasw7f3rvr95g8d37yh3vmwk6arj8dq"))))
(build-system cmake-build-system)
- (arguments
- (list #:phases #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (invoke "dbus-launch" "ctest")))))))
(native-inputs
- (list bison dbus extra-cmake-modules flex qttools-5))
- (inputs
- (list qtbase-5 qtdeclarative-5 eudev))
+ (list bison dbus extra-cmake-modules flex qttools))
;; TODO: Add runtime-only dependency MediaPlayerInfo
+ (inputs
+ (list `(,util-linux "lib") ;; Optional, for libmount
+ libxkbcommon
+ vulkan-headers
+ qtbase qtdeclarative eudev))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Desktop hardware abstraction")
(description "Solid is a device integration framework. It provides a way of