aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-09-15 09:20:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-09-15 10:45:39 +0200
commit08a18cb05a1af8f3a9f53b284d6ea96a0c5fc726 (patch)
tree75837d6d39ba6e840668dab5cca7e91909799cfa /gnu
parent556c73d14a1dd0de07a65be52511570cfb7ae2de (diff)
downloadguix-08a18cb05a1af8f3a9f53b284d6ea96a0c5fc726.tar.gz
guix-08a18cb05a1af8f3a9f53b284d6ea96a0c5fc726.zip
gnu: emacs-eglot-tempel: Update to 0.8.
* gnu/packages/emacs-xyz.scm (emacs-eglot-tempel): Update to 0.8. [arguments]<#:phases>: Fix a failing test. [propagated-inputs]: Add EMACS-PEG. Change-Id: I8bd7223a808a3543935c84308d8a6c6a23999dd4
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm59
1 files changed, 32 insertions, 27 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6e6f1729cc..73327e890d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12747,34 +12747,39 @@ call.")
(license license:gpl3+)))
(define-public emacs-eglot-tempel
- (let ((commit "e08b203d6a7c495d4b91ed4537506b5f1ea8a84f")
- (revision "0"))
- (package
- (name "emacs-eglot-tempel")
- (version (git-version "0.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/fejfighter/eglot-tempel")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0f4m0bb1f91x9jqfc0ny95a3pfh1mzzjzdjpa6f548hynq8j34ib"))))
- (build-system emacs-build-system)
- (arguments
- (list
- #:tests? #true
- #:test-command #~(list "emacs" "-Q" "-batch"
- "-l" "eglot-tempel-tests.el"
- "-f" "ert-run-tests-batch-and-exit")))
- (native-inputs (list emacs-ert-runner))
- (propagated-inputs (list emacs-eglot emacs-tempel))
- (home-page "https://github.com/fejfighter/eglot-tempel")
- (synopsis "Bridge for Tempel templates with Eglot")
- (description "This package is an adapter to use the Tempel templating
+ (package
+ (name "emacs-eglot-tempel")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fejfighter/eglot-tempel")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nbx0k6ly207j9lv686mqa554rhqpfxm6smgfqrdyrrfj6674zr8"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #true
+ #:test-command #~(list "emacs" "-Q" "-batch"
+ "-l" "eglot-tempel-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'skip-failing-test
+ (lambda _
+ (substitute* "eglot-tempel-tests.el"
+ (("\\(ert-deftest test-named .*" all)
+ (string-append all " (skip-unless nil)"))))))))
+ (native-inputs (list emacs-ert-runner))
+ (propagated-inputs (list emacs-eglot emacs-peg emacs-tempel))
+ (home-page "https://github.com/fejfighter/eglot-tempel")
+ (synopsis "Bridge for Tempel templates with Eglot")
+ (description "This package is an adapter to use the Tempel templating
library with Eglot instead of Yasnippet.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-eglot-jl
(package