aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 15:43:52 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:55 +0200
commit089add98d20447de2657cb0504b51681382561a7 (patch)
tree4017938548322edbc262357f2ee2dd78b07b191a /gnu
parent4d171bf03faa5cf16b4d99a023c24d81c8d39e75 (diff)
downloadguix-089add98d20447de2657cb0504b51681382561a7.tar.gz
guix-089add98d20447de2657cb0504b51681382561a7.zip
gnu: Add texlive-arabxetex.
* gnu/packages/tex.scm (texlive-arabxetex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4ca991e439..4207af65ed 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12836,6 +12836,68 @@ the @code{psnfss} distribution.")
;; Either LPPL version 1.0 or later, or GPL version 2
(license (list license:lppl1.0+ license:gpl2))))
+(define-public texlive-arabxetex
+ (package
+ (name "texlive-arabxetex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/xelatex/arabxetex/"
+ "fonts/misc/xetex/fontmapping/arabxetex/"
+ "source/xelatex/arabxetex/"
+ "tex/xelatex/arabxetex/")
+ (base32
+ "097lh7ksw9rg93f1c7a4fqglgfpydf1qp3sbgy9xfgszcdpknmrk")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list
+ #:tex-format "xelatex"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Use dummy fonts to avoid pulling in needless dependencies.
+ ;; We're only interested in building the package, not the
+ ;; documentation.
+ (add-after 'unpack 'change-fonts
+ (lambda _
+ (substitute* "source/xelatex/arabxetex/arabxetex.dtx"
+ (("(newfontfamily.*?\\{)[^}]+}" _ prefix)
+ (string-append prefix "FreeSans}"))
+ (("(set(main|mono|sans)font(\\[.*?])?\\{)[^}]+}" _ prefix)
+ (string-append prefix "FreeSans}"))))))))
+ (native-inputs
+ (list fontconfig
+ font-gnu-freefont
+ texlive-amsmath
+ texlive-amsfonts
+ texlive-bidi
+ texlive-fancyvrb
+ texlive-fontspec
+ texlive-hologo
+ texlive-hypdoc
+ texlive-hyperref
+ texlive-infwarerr
+ texlive-kvdefinekeys
+ texlive-kvoptions
+ texlive-kvsetkeys
+ texlive-ltxcmds
+ texlive-paralist
+ texlive-pdftexcmds
+ texlive-supertabular
+ texlive-tools
+ texlive-xetex
+ texlive-xkeyval
+ texlive-zref))
+ (home-page "https://ctan.org/pkg/arabxetex")
+ (synopsis "ArabTeX-like interface for XeLaTeX")
+ (description
+ "ArabXeTeX provides a convenient ArabTeX-like user-interface for
+typesetting languages using the Arabic script in XeLaTeX, with flexible access
+to font features. Input in ArabTeX notation can be set in three different
+vocalization modes or in roman transliteration. Direct UTF-8 input is also
+supported.")
+ (license license:lppl1.3c)))
+
(define-public texlive-arev
(package
(name "texlive-arev")