aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFries <fries1234@protonmail.com>2023-08-05 11:01:33 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:42 +0100
commit083a3aefb0006cd4604856eab8a6dff250c783b0 (patch)
treeb1285daa1e3afbf19ee0d1d57c00d92cf2284d75 /gnu
parentfafa7e562e2f4070a938b919369f951852085bf5 (diff)
downloadguix-083a3aefb0006cd4604856eab8a6dff250c783b0.tar.gz
guix-083a3aefb0006cd4604856eab8a6dff250c783b0.zip
gnu: Add go-github-com-chzyer-readline.
* gnu/packages/golang-xyz.scm (go-github-com-chzyer-readline): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I33eca16e71838a3b2a6dbe2610532e16012e3920
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5f0dbf2bc4..b1836da249 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -635,6 +635,34 @@ similar to Go's standard library @code{json} and @code{xml} package.")
levels that works by wrapping the standard @code{log} library.")
(license license:expat)))
+(define-public go-github-com-chzyer-readline
+ (package
+ (name "go-github-com-chzyer-readline")
+ (version "1.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chzyer/readline")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1msh9qcm7l1idpmfj4nradyprsr86yhk9ch42yxz7xsrybmrs0pb"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/chzyer/readline"))
+ (native-inputs
+ (list go-github-com-chzyer-test))
+ (propagated-inputs
+ (list go-github-com-chzyer-logex
+ go-golang-org-x-sys))
+ (home-page "https://github.com/chzyer/readline")
+ (synopsis "Pure Go readline library")
+ (description
+ "Readline is a pure Go implementation of a GNU-Readline like library.")
+ (license license:expat)))
+
(define-public go-github-com-coocood-freecache
(package
(name "go-github-com-coocood-freecache")