aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-10-29 18:48:28 +0200
committerDavid Craven <david@craven.ch>2016-10-29 23:51:43 +0200
commit075eeb355b3970cb14b391df28760d6c4ae051f6 (patch)
treedb2654c5578ea9f1662ee9635f1c7fcff45d5d8b /gnu
parent17b5144a1872cd6282b0c933b146fec4ea81f55e (diff)
downloadguix-075eeb355b3970cb14b391df28760d6c4ae051f6.tar.gz
guix-075eeb355b3970cb14b391df28760d6c4ae051f6.zip
gnu: kcrash: Update to 5.27.0.
* gnu/packages/kde-frameworks.scm (kcrash): Update to 5.27.0 and fix indentation.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index ab0ceb8f26..7c37f5f6dd 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1196,16 +1196,16 @@ integrated it into your application's other widgets.")
(define-public kcrash
(package
(name "kcrash")
- (version "5.24.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/frameworks/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1lahgfwlp9b5rsl244kzp7rsl4ybv1q4qlvpv0xxz5ygssk48l0w"))))
+ (version "5.27.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "09wf4dzckc9l8dyl8qs1wc54h4rm38i2blzyyicm4iazi420lysk"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -1217,13 +1217,13 @@ integrated it into your application's other widgets.")
("qtx11extras" ,qtx11extras)))
(arguments
`(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'start-xorg-server
- (lambda* (#:key inputs #:allow-other-keys)
- ;; The test suite requires a running X server.
- (system (string-append (assoc-ref inputs "xorg-server")
- "/bin/Xvfb :1 &"))
- (setenv "DISPLAY" ":1")
+ (modify-phases %standard-phases
+ (add-before 'check 'start-xorg-server
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; The test suite requires a running X server.
+ (system (string-append (assoc-ref inputs "xorg-server")
+ "/bin/Xvfb :1 &"))
+ (setenv "DISPLAY" ":1")
#t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Graceful handling of application crashes")
ic Courtès 2023-07-14doc: Mention gexps in the "Scheme Crash Course"....Ludovic Courtès 2023-06-05doc: cookbook: Update example my-libgit2 package....Efraim Flashner 2023-06-04services: screen-locker-service-type: Configurable PAM and setuid....muradm 2023-05-31nls: Update translations....Florian Pelz 2023-05-06doc: cookbook: Remove outdated section about GUIX_PACKAGE_PATH....Ludovic Courtès 2023-01-09doc: cookbook: Add "Installing Guix on a Cluster" chapter....Ludovic Courtès 2023-01-06doc: cookbook: Remove 404 link to mitpress.mit.edu....Ludovic Courtès 2022-11-27doc: cookbook: Fix commands in example....Florian Pelz 2022-11-24doc: Add a security keys section to the cookbook....Maxim Cournoyer 2022-11-06doc: cookbook: Add section on MPD with bluealsa....Ricardo Wurmus 2022-11-06doc: cookbook: Update detailed menu for "System Configuration"....Ricardo Wurmus 2022-10-13doc: Add chapter on containers to Cookbook....Ricardo Wurmus 2022-07-08doc: cookbook: Link to "A Scheme Primer"....Ludovic Courtès 2022-07-08doc: cookbook: Suggest 'guix shell'....Ludovic Courtès 2022-06-01doc: cookbook: Refer to the "Writing Manifests" manual node....Ludovic Courtès