aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2023-12-09 21:38:34 +0100
committerW. Kosior <koszko@koszko.org>2024-05-03 14:46:55 +0200
commit06ffa118eb9c20ec9b2ea57cee1c4bb01e9abea9 (patch)
tree1dc3d0a727e5232b707fe8c3b99809fae0effe52 /gnu
parent9fabf34a28eb7741ceb8ab2f62d58ff73ae9e834 (diff)
downloadguix-06ffa118eb9c20ec9b2ea57cee1c4bb01e9abea9.tar.gz
guix-06ffa118eb9c20ec9b2ea57cee1c4bb01e9abea9.zip
gnu: Add guile-cantius.
* gnu/packages/guile-xyz.scm (guile-cantius): New variable. Change-Id: Iccc7385ae5c3f762f53705c8ebe876f7ad08da00
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 1d115a2f59..42d3a1825e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4723,6 +4723,35 @@ This library is inspired by the Guix records API but follows purely functional
approach.")
(license license:cc0)))
+(define-public guile-cantius
+ (package
+ (name "guile-cantius")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.koszko.org/cantius")
+ (commit "67811d35e09a6a638c6a8e92b6824beb5a631838")))
+ (sha256
+ (base32
+ "0kqawxp5l0bpzvbpwlsrk18d6wwza6zcrs192zppchmdzl4w0qh4"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf
+ automake
+ guile-3.0
+ pkg-config
+ lawrence-boilerplate))
+ (inputs
+ (list guile-3.0 guile-myra-test-utils))
+ (propagated-inputs
+ (list guile-fibers guile-srfi-146 guile-srfi-128 guile-de-paul-records))
+ (home-page "https://git.koszko.org/cantius/about")
+ (synopsis "HTTP server library for GNU Guile")
+ (description "Cantius aims to simplify writing of web services in Guile.
+It builds upon @code{(fibers web server)}.")
+ (license license:cc0)))
+
(define-public guile-semver
(package
(name "guile-semver")