aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-22 18:46:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:41 +0200
commit06f20053b56f5265d4070dac45df9cef84692b34 (patch)
tree27f3afdcc2d5d6c3615b4cbffe4d5fc0bb485fad /gnu
parentcfa8d2a9f7ddd222225269084a38edba4f703949 (diff)
downloadguix-06f20053b56f5265d4070dac45df9cef84692b34.tar.gz
guix-06f20053b56f5265d4070dac45df9cef84692b34.zip
gnu: Add rust-p521-0.13.
* gnu/packages/crates-crypto.scm (rust-p521-0.13): New variable. Change-Id: I3cf54c7b600f38f15e6006d4f6870bdd868781ed
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-crypto.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index d43f0c89b9..c6280fbd27 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -3345,6 +3345,42 @@ secp384r1) elliptic curve as defined in SP 800-186 with support for ECDH, ECDSA
signing/verification, and general purpose curve arithmetic support.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-p521-0.13
+ (package
+ (name "rust-p521")
+ (version "0.13.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "p521" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1cl5y2aypa1vxg181a0na3abndz1981pfdp2zkyml88z3wbf5j8g"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-base16ct" ,rust-base16ct-0.2)
+ ("rust-ecdsa" ,rust-ecdsa-0.16)
+ ("rust-elliptic-curve" ,rust-elliptic-curve-0.13)
+ ("rust-hex-literal" ,rust-hex-literal-0.4)
+ ("rust-primeorder" ,rust-primeorder-0.13)
+ ("rust-rand-core" ,rust-rand-core-0.6)
+ ("rust-serdect" ,rust-serdect-0.2)
+ ("rust-sha2" ,rust-sha2-0.10))
+ #:cargo-development-inputs (("rust-blobby" ,rust-blobby-0.3)
+ ("rust-ecdsa" ,rust-ecdsa-0.16)
+ ("rust-hex-literal" ,rust-hex-literal-0.4)
+ ("rust-primeorder" ,rust-primeorder-0.13)
+ ("rust-proptest" ,rust-proptest-1)
+ ("rust-rand-core" ,rust-rand-core-0.6))))
+ (home-page
+ "https://github.com/RustCrypto/elliptic-curves/tree/master/p521")
+ (synopsis
+ "Pure Rust implementation of the NIST P-521 (a.k.a. secp521r1) elliptic curve")
+ (description
+ "This package provides Pure Rust implementation of the NIST P-521 (a.k.a.
+secp521r1) elliptic curve as defined in SP 800-186.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-pbkdf2-0.12
(package
(name "rust-pbkdf2")