aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-06 12:23:37 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:48 -0500
commit0677b1af3bc7574a29c0ec6618042abaf3f50a53 (patch)
tree8964ab8f222c93a38378d25ee4e89e4701e447f5 /gnu
parent70de16eaf41a0b4d402ca89678e90f326190fc04 (diff)
downloadguix-0677b1af3bc7574a29c0ec6618042abaf3f50a53.tar.gz
guix-0677b1af3bc7574a29c0ec6618042abaf3f50a53.zip
gnu: Add Throwable.
* gnu/packages/perl.scm (perl-throwable): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 9090046ac2..eb2a0c0e08 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4438,6 +4438,31 @@ letters, the pronunciation expressed by the text in some other writing
system.")
(license (package-license perl))))
+(define-public perl-throwable
+ (package
+ (name "perl-throwable")
+ (version "0.200012")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/"
+ "Throwable-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0cy8kza9pd9y5m7k5385asf4xqm54vdqnqm0am10z6j2mrxwr527"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-devel-stacktrace" ,perl-devel-stacktrace)))
+ (propagated-inputs
+ `(("perl-devel-stacktrace" ,perl-devel-stacktrace)
+ ("perl-module-runtime" ,perl-module-runtime)
+ ("perl-moo" ,perl-moo)))
+ (home-page "http://search.cpan.org/dist/Throwable")
+ (synopsis "Role for classes that can be thrown")
+ (description "Throwable is a role for classes that are meant to be thrown
+as exceptions to standard program flow.")
+ (license (package-license perl))))
+
(define-public perl-tie-ixhash
(package
(name "perl-tie-ixhash")