aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-16 11:46:11 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:23 +0000
commit058a17ed5e2c56132301097ad6ea7b881a95f5bf (patch)
tree5b6f35b97ed51bebb0cfa9892ea05243012c7289 /gnu
parent3355db5729a01a36082227ea298276f111b5a107 (diff)
downloadguix-058a17ed5e2c56132301097ad6ea7b881a95f5bf.tar.gz
guix-058a17ed5e2c56132301097ad6ea7b881a95f5bf.zip
gnu: python-pytest-mypy: Update to 0.10.3.
* gnu/packages/check.scm (python-pytest-mypy): Update to 0.10.3. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Ic0483fe3c430c00ea82e9f54e60632ce48f79e75
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm21
1 files changed, 16 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c07b0dc91d..67166951db 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2933,17 +2933,28 @@ by the test.")
(define-public python-pytest-mypy
(package
(name "python-pytest-mypy")
- (version "0.9.1")
+ (version "0.10.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-mypy" version))
(sha256
- (base32 "0p5bd4r4gbwk1h7mpx1jkhdwkckapfz24bp9x5mmqb610ps3pylz"))))
- (build-system python-build-system)
- (native-inputs (list python-setuptools-scm))
+ (base32 "1nyk9xxkwb03sp6avn5l4ysncybnyw4ibrp2lcn3mw934dj8yigq"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags #~(list "--numprocesses" "auto")))
+ (native-inputs
+ (list python-pexpect
+ python-pytest-xdist
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs
- (list python-attrs python-filelock python-mypy python-pytest))
+ (list python-attrs
+ python-filelock
+ python-mypy
+ python-pytest))
(home-page "https://github.com/dbader/pytest-mypy")
(synopsis "Mypy static type checker plugin for Pytest")
(description "@code{pytest-mypi} is a static type checker plugin for