aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:36 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:35 +0200
commit04edfcf7debed4a1db8fe2eac5f5f08615c1d80d (patch)
treedb6de49773e152fe6d6c53106352c207c521c680 /gnu
parent261c7692e41f7c977d01a61b31269dc3aba61da7 (diff)
downloadguix-04edfcf7debed4a1db8fe2eac5f5f08615c1d80d.tar.gz
guix-04edfcf7debed4a1db8fe2eac5f5f08615c1d80d.zip
gnu: guile-xyz: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/guile-xyz.scm (artanis)[inputs]: Add 'bash-minimal'. (guile-hall)[inputs]: Likewise. (python-on-guile)[inputs]: Likewise. (haunt)[inputs]: Likewise. (emacsy)[inputs]: Likewise. (nomad)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I496c2ac6d7e9a9266dc57cdbc9ada434968d9bac
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile-xyz.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index e6863ff004..5a51c98186 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -187,7 +187,7 @@
#t))))
(build-system gnu-build-system)
(inputs
- (list guile-3.0 nspr nss))
+ (list bash-minimal guile-3.0 nspr nss))
;; FIXME the bundled csv contains one more exported procedure
;; (sxml->csv-string) than guile-csv. The author is maintainer of both
;; projects.
@@ -3051,14 +3051,13 @@ inspired by the SCSH regular expression system.")
(string-append dep "/lib/guile/"
version
"/site-ccache"))
- deps))))
- #t)))))))))
+ deps)))))))))))))
(native-inputs
(list pkg-config texinfo))
(inputs
;; Depend on the latest Guile to avoid bytecode compatibility issues when
;; using modules built against the latest version.
- (list guile-3.0-latest))
+ (list bash-minimal guile-3.0-latest))
(propagated-inputs
(list guile-reader guile-commonmark))
(synopsis "Functional static site generator")
@@ -3459,8 +3458,7 @@ serializing continuations or delimited continuations.")
;; TODO: It would be better to patch the Makefile.
(setenv "GUILE_LOAD_PATH"
(string-append ".:"
- (getenv "GUILE_LOAD_PATH")))
- #t))
+ (getenv "GUILE_LOAD_PATH")))))
(add-after 'install 'wrap
(lambda* (#:key outputs #:allow-other-keys)
;; Wrap the 'python' executable so it can find its
@@ -3485,10 +3483,9 @@ serializing continuations or delimited continuations.")
`("GUILE_LOAD_PATH" ":" prefix
(,load-path))
`("GUILE_LOAD_COMPILED_PATH" ":" prefix
- (,compiled-path)))
- #t))))))
+ (,compiled-path)))))))))
(inputs
- (list guile-3.0 guile-persist guile-readline guile-stis-parser))
+ (list bash-minimal guile-3.0 guile-persist guile-readline guile-stis-parser))
(native-inputs
(list autoconf automake libtool pkg-config))
(synopsis "Python implementation in Guile")
@@ -4120,7 +4117,8 @@ applied to surplus arguments.")
("texinfo" ,texinfo)
("texlive" ,(texlive-updmap.cfg (list texlive-epsf)))))
(inputs
- (list dbus-glib
+ (list bash-minimal
+ dbus-glib
guile-3.0
guile-lib
guile-readline
@@ -4330,7 +4328,8 @@ processing filters.")
("gettext" ,gettext-minimal)
("perl" ,perl)))
(inputs
- `(;; Guile
+ `(("bash" ,bash-minimal) ; for wrap-program
+ ;; Guile
("guile" ,guile-2.2)
("guile-lib" ,guile2.2-lib)
("guile-readline" ,guile2.2-readline)