aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 22:21:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:08 +0200
commit047c2c453bf842f73ffc25138c5f6b8e2dfec981 (patch)
tree13544a0c9a4a6c02ad63104a434f2d6d1e8d9389 /gnu
parent8d31456bc11481af132fb6dde03f9460db47e857 (diff)
downloadguix-047c2c453bf842f73ffc25138c5f6b8e2dfec981.tar.gz
guix-047c2c453bf842f73ffc25138c5f6b8e2dfec981.zip
gnu: Add texlive-dpcircling.
* gnu/packages/tex.scm (texlive-dpcircling): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 08ea5c6745..c5f04212ac 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16832,6 +16832,29 @@ in your document (DOT and Neato are both part of @code{graphviz}; DOT creates
directed graphs, Neato undirected graphs).")
(license license:gpl3+)))
+(define-public texlive-dpcircling
+ (package
+ (name "texlive-dpcircling")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/dpcircling/"
+ "tex/latex/dpcircling/")
+ (base32
+ "0wpskh9rixgjvn4h5kand9ggiqa2mqca5fc0l565pxq8a9sq2bm0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/dpcircling")
+ (synopsis "Decorated text boxes using TikZ")
+ (description
+ "This simple package provides four types of text decorations using TikZ.
+You can frame your text with circles, rectangles, jagged rectangles, and
+fan-shapes. The baseline will be adjusted properly according to the
+surroundings. You can use these decorations both in text mode and in math
+mode. You can specify line color, line width, width, and height using option
+keys.")
+ (license license:expat)))
+
(define-public texlive-gates
(package
(name "texlive-gates")