aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-28 00:43:13 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-05-08 12:42:09 +0300
commit02dbaa03115d45df15e2f5d2d005985e209527c9 (patch)
tree0bb0d36a7805a35a5e19b90f58392027f574ffcf /gnu
parent596f3beeb78609c1bbc000dbc56be87229e5d840 (diff)
downloadguix-02dbaa03115d45df15e2f5d2d005985e209527c9.tar.gz
guix-02dbaa03115d45df15e2f5d2d005985e209527c9.zip
gnu: python-astropy: Update to 5.2.2.
* gnu/packages/astronomy.scm (python-astropy): Update to 5.2.2. [arguments]<phases>{check}: Skip 2 more failing tests. [native-inputs]: Add python-colorlog, python-h5py, python-pandas, python-pyarrow, python-pytest-astropy-header, python-scikit-image, python-scipy, python-timezonefinder. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm21
1 files changed, 17 insertions, 4 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 5a104c752c..9bc790ef4b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -41,6 +41,7 @@
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages geo)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
@@ -1131,13 +1132,13 @@ accurately in real time at any rate desired.")
(define-public python-astropy
(package
(name "python-astropy")
- (version "5.2.1")
+ (version "5.2.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "astropy" version))
(sha256
- (base32 "08xc6brs7xwiqchhsjq8l10p6qc5p68cfxps7s889spqfyh2gbpn"))
+ (base32 "170ddflli35mvhf6pla7aizfw8a7ckq66g1mi1br99dx2r3y7ag6"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1187,21 +1188,33 @@ accurately in real time at any rate desired.")
(invoke "python" "setup.py" "build_ext" "--inplace")
(invoke "python" "-m" "pytest" "--pyargs" "astropy"
;; Skip tests that need remote data.
- "-m" "not remote_data")))))))
+ "-k" (string-append
+ "not remote_data"
+ ;; XXX: Check why this tests failing.
+ " and not test_ignore_sigint"
+ " and not test_parquet_filter"))))))))
(native-inputs
(list pkg-config
+ python-colorlog
python-coverage
python-cython
python-extension-helpers
+ python-h5py
python-ipython
python-jplephem
python-objgraph
+ python-pandas
+ python-pyarrow
python-pytest
python-pytest-astropy
+ python-pytest-astropy-header
python-pytest-xdist
+ python-scikit-image
+ python-scipy
python-setuptools-scm
python-sgp4
- python-skyfield))
+ python-skyfield
+ python-timezonefinder))
(inputs
(list cfitsio expat wcslib))
(propagated-inputs