aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-07 21:24:17 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-30 19:32:17 +0000
commit01dbeb3cf245480ac3eb8091a1fc25ff630a7cf3 (patch)
tree024024ae6e6f3349ce580f39f61ff70a6ce6dea3 /gnu
parentb028dea4052899a67a77a5939b97bec01d5433ad (diff)
downloadguix-01dbeb3cf245480ac3eb8091a1fc25ff630a7cf3.tar.gz
guix-01dbeb3cf245480ac3eb8091a1fc25ff630a7cf3.zip
gnu: python-tweakwcs: Update to 0.8.9.
* gnu/packages/astronomy.scm (python-tweakwcs): Update to 0.8.9. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I0d00a9964ee10711a0f751990939633d07634282
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index f92917644c..dbb477a3e7 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -6116,13 +6116,13 @@ orbit around the Earth.")
(define-public python-tweakwcs
(package
(name "python-tweakwcs")
- (version "0.8.8")
+ (version "0.8.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tweakwcs" version))
(sha256
- (base32 "148as0x1szk1wv13bwk947qs3rw5xj2286ccdbhzfzarng58a386"))))
+ (base32 "0a1ygsar9l6jybji9qibz6ja3picv9aiw2jmdcsqdfqhrppknqp7"))))
(build-system pyproject-build-system)
(propagated-inputs
(list python-astropy
@@ -6137,7 +6137,9 @@ orbit around the Earth.")
python-pytest
python-pytest-cov
python-scipy
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://tweakwcs.readthedocs.io/en/latest/")
(synopsis
"Algorithms for matching and aligning catalogs and for tweaking the WCS")