aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-17 19:37:57 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:25 +0000
commit00dfba9d7518d9a9900adeb553b6a2231454cbe8 (patch)
treec2251191978bc1e22febd4e1bcf673f0b3285f5c /gnu
parentf2fa9e8a9f88875fb0172164f394ad839f2f0d2f (diff)
downloadguix-00dfba9d7518d9a9900adeb553b6a2231454cbe8.tar.gz
guix-00dfba9d7518d9a9900adeb553b6a2231454cbe8.zip
gnu: python-cloudpickle: Update to 3.1.0.
This change merges python-cloudpickle-testpkg and python-cloudpickle under the same variable name - python-cloudpickle, which was split 3y ago. Build and check phases passed just fine. * gnu/packages/python-xyz.scm (python-cloudpickle): Update to 3.1.0. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-flit-core. Remove python-cloudpickle-testpkg, python-tornado-6. (python-cloudpickle-testpkg): Delete variable. Change-Id: I4f3a31f127a9079e50a0334ee55d50f61e726009
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm45
1 files changed, 8 insertions, 37 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index db88bd1bfc..5263ea3fb4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29297,10 +29297,10 @@ that is accessible to other projects developed in Cython.")
pure-Python.")
(license license:asl2.0)))
-(define python-cloudpickle-testpkg
+(define-public python-cloudpickle
(package
- (name "python-cloudpickle-testpkg")
- (version "1.6.0")
+ (name "python-cloudpickle")
+ (version "3.1.0")
(source
(origin
;; Archive on pypi does not include test infrastructure.
@@ -29310,41 +29310,12 @@ pure-Python.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "1584d21d4rcpryn8yfz0pjnjprk4zm367m0razdcz8cjbsh0dxp6"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _ (chdir "tests/cloudpickle_testpkg"))))))
- (home-page "https://github.com/cloudpipe/cloudpickle")
- (synopsis "Extended pickling support for Python objects")
- (description
- "Cloudpickle makes it possible to serialize Python constructs not
-supported by the default pickle module from the Python standard library. It
-is especially useful for cluster computing where Python expressions are
-shipped over the network to execute on remote hosts, possibly close to the
-data.")
- (license license:bsd-3)))
-
-(define-public python-cloudpickle
- (package
- (inherit python-cloudpickle-testpkg)
- (name "python-cloudpickle")
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- (invoke "pytest" "-s" "-vv")
- (format #t "test suite not run~%")))))))
+ (base32 "16z0jdg5b1r23vw1l0bwsg40zcmnrbznr4frjac9kq5j6jm4fw6d"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list ;; For tests.
- python-cloudpickle-testpkg python-psutil python-pytest
- python-tornado-6))
+ (list python-flit-core
+ python-psutil
+ python-pytest))
(home-page "https://github.com/cloudpipe/cloudpickle")
(synopsis "Extended pickling support for Python objects")
(description