aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-05-06 14:32:48 +0100
committerChristopher Baines <mail@cbaines.net>2022-05-06 14:38:52 +0100
commit83c1f017a6fd3de45c32ed9ad9e3d070350786ad (patch)
tree087229a758aff689a7d6084c80fa84e9f561edb9 /gnu/tests
parent4f15745b954d9dea53a6a4a79beec22b895a8a4a (diff)
downloadguix-83c1f017a6fd3de45c32ed9ad9e3d070350786ad.tar.gz
guix-83c1f017a6fd3de45c32ed9ad9e3d070350786ad.zip
gnu: nar-herder: Update to 0-6.ea997c6.
* gnu/packages/package-management.scm (nar-herder): Update to 0-6.ea997c6.
Diffstat (limited to 'gnu/tests')
0 files changed, 0 insertions, 0 deletions
diff/gnu/packages/jupyter.scm?id=3f66c30dbdee18bf5922bdc6c6d86697d1732314'>gnu/packages/jupyter.scm19
1 files changed, 17 insertions, 2 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index bea53ba912..d517712bcb 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -21,6 +21,7 @@
(define-module (gnu packages jupyter)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -215,15 +216,29 @@ the JupyterLab CSS variables.")
(define-public python-jupyter-packaging
(package
(name "python-jupyter-packaging")
- (version "0.9.1")
+ (version "0.12.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jupyter_packaging" version))
(sha256
(base32
- "0r015c0m713d19asmpimsw6bk2sqv2lpd2nccgjzjdj5h1crg0bg"))))
+ "1b7ssc627vgrdl21c09w9sxk5fc1ps3g7f70laxag4yw1bb5ax5j"))))
(build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Disable isolation so that the package environment can be
+ ;; setup without connectivity.
+ (setenv "SOURCE_DATE_EPOCH" "315532800")
+ (substitute* "tests/test_build_api.py"
+ (("\"-m\", \"build\"" all)
+ (string-append all ", \"--no-isolation\"")))
+ (invoke "python" "-m" "pytest" "-vv")))))))
(propagated-inputs
(list python-deprecation python-packaging python-setuptools
python-tomlkit python-wheel))