aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-31 12:15:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-31 18:19:53 +0200
commit30d49c8dd7048ae302ce65c6ff0d5e21b71e8f46 (patch)
treeb2f3890ba3f65d337787c1ba21e311105009ad5c /gnu/tests
parent72e06ca299488dc161e7360b060985e31d28ce4c (diff)
downloadguix-30d49c8dd7048ae302ce65c6ff0d5e21b71e8f46.tar.gz
guix-30d49c8dd7048ae302ce65c6ff0d5e21b71e8f46.zip
gnu: r-clock: Update to 0.7.0.
* gnu/packages/cran.scm (r-clock): Update to 0.7.0. [propagated-inputs]: Add r-cli and r-lifecycle.
Diffstat (limited to 'gnu/tests')
0 files changed, 0 insertions, 0 deletions
ed, 4 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4a88d17f6c..097a67f20b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4189,7 +4189,7 @@ sensitive completion, colors, and more.")
(define-public ocaml-integers
(package
(name "ocaml-integers")
- (version "0.5.1")
+ (version "0.6.0")
(home-page "https://github.com/ocamllabs/ocaml-integers")
(source (origin
(method git-fetch)
@@ -4199,10 +4199,12 @@ sensitive completion, colors, and more.")
(file-name (git-file-name name version))
(sha256
(base32
- "0by5pc851fk7ccxqy1w2qc5jwn9z8whyqhs5gxlm5986vr9msnyi"))))
+ "07qk7dgxykn528qvhfwa0j402yr58y1y84ivpi1ji1lvk0qddxcs"))))
(build-system dune-build-system)
(arguments
`(#:tests? #f)) ; no tests
+ (propagated-inputs
+ (list ocaml-stdlib-shims))
(synopsis "Various signed and unsigned integer types for OCaml")
(description "The ocaml-integers library provides a number of 8-, 16-, 32-
and 64-bit signed and unsigned integer types, together with aliases such as