aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests/ldap.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-02-17 09:40:19 -0300
committerVinicius Monego <monego@posteo.net>2024-03-23 09:30:45 -0300
commitbf530017f0e847ae895919b32ef37d79fa636a1e (patch)
tree66a22bb4fc738a8c8a63c93c3c8eb1c7116ae567 /gnu/tests/ldap.scm
parent1e103064607ab2d6668559da1de84cded5247e10 (diff)
downloadguix-bf530017f0e847ae895919b32ef37d79fa636a1e.tar.gz
guix-bf530017f0e847ae895919b32ef37d79fa636a1e.zip
gnu: libdjinterop: Update to 0.20.2.
* gnu/packages/audio.scm (libdjinterop): Update to 0.20.2. [build-system]: Use cmake-build-system. [arguments]: Delete the make-git-checkout-writable phase. Change-Id: I0e5c96834ce16d159479a30ab6089aa727a6d8d1
Diffstat (limited to 'gnu/tests/ldap.scm')
0 files changed, 0 insertions, 0 deletions
ov <go.wigust@gmail.com>
;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,6 +35,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages ssh)
+ #:use-module (guix gexp)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
@@ -940,3 +942,62 @@ Ed25519 keys.
@item Modern browsers are supported.
@end itemize")
(license license:expat)))
+
+(define-public x11-ssh-askpass
+ (package
+ (name "x11-ssh-askpass")
+ (version "1.2.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ ;; The project home page seams to be offline.
+ (uri (string-append "https://pkgs.fedoraproject.org/repo/pkgs/openssh/"
+ name "-" version ".tar.gz"
+ "/8f2e41f3f7eaa8543a2440454637f3c3/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32 "124c1frwvdmg4nv8xqv435ibjhj2y8xc1bmfr6i8a8g75b1y63b2"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:make-flags
+ #~(list (string-append "BINDIR=" #$output "/libexec")
+ (string-append "MANDIR=" #$output "/share/man"))
+ #:configure-flags
+ #~(list (string-append "--mandir="
+ "/usr/share/man/test")
+ (string-append "--libexecdir="
+ "/usr/lib/ssh/test")
+ (string-append "--with-app-defaults-dir="
+ "/usr/share/X11/app-defaults/test"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'configure 'xmkmf
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((imake #$(this-package-native-input "imake")))
+ (invoke "xmkmf")
+ (substitute* "Makefile"
+ ;; These imake variables somehow remain undefined
+ (("DefaultGcc2[[:graph:]]*Opt") "-O2")
+ ;; Reset a few variable defaults that are set in imake
+ ;; templates.
+ ((imake) #$output)
+ (("(MANPATH = )[[:graph:]]*" _ front)
+ (string-append front #$output "/share/man"))))))
+ (add-after 'xmkmf 'make-includes
+ (lambda _
+ (invoke "make" "includes")))
+ (add-after 'install 'install/doc
+ (lambda _
+ (lambda _
+ (invoke "make"
+ (string-append "MANDIR=" #$output "/share/man")
+ "install.man")))))))
+ (native-inputs (list imake))
+ (inputs (list libxt))
+ (home-page "http://www.jmknoble.net/software/x11-ssh-askpass/")
+ (synopsis "Lightweight passphrase dialog for SSH")
+ (description "code{x11-ssh-askpass} is an X11-based pass-phrase dialog for
+use with OpenSSH.")
+ (license license:gpl2+)))