aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/telephony.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-06 19:27:16 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 19:49:57 +0200
commite7f0835b07d868fd447aa64c873174fa385e1699 (patch)
tree3efa83a3582108d3cca61a8e0a4cdbcd5605c46b /gnu/services/telephony.scm
parent79878c64b4bda523f50974c3f61b796309b1b8d9 (diff)
downloadguix-e7f0835b07d868fd447aa64c873174fa385e1699.tar.gz
guix-e7f0835b07d868fd447aa64c873174fa385e1699.zip
gnu: nss: Use (guix utils).
* gnu/packages/nss.scm (nss)[arguments]: Utilize CC-FOR-TARGET and TARGET-64bit?.
Diffstat (limited to 'gnu/services/telephony.scm')
0 files changed, 0 insertions, 0 deletions
T
@@ -49,3 +51,40 @@
`WRITE(012302, 0fca0000)
`WRITE(012306, 0000baca)
`READ (012304, baca0fca)
+
+
+//// Second half with non-aligned accesses and weird SEL_O patterns starts here
+
+`WRITE (200013, afe8b317)
+`READ (200013, afe8b317)
+
+`WRITES(140022, xxxxd0d3, 3) // Only select 2 bottom bytes
+`READS (140022, xxxxd0d3, 3)
+
+`WRITES(140022, xx48e2xx, 6) // Only select 2 middle bytes
+`READS (140022, xx48e2xx, 6)
+`READS (140022, xx48e2d3, f) // Select 3 bottom bytes
+
+`WRITES(140025, xxxxxx72, 1) // Single byte write at odd address
+`WRITES(140024, xxxx7248, 3)
+`READS (140023, xx7248e2, 7) // Non-aligned read
+
+`DESELECT
+
+// Some other complicated stuff
+`WRITES(2013e4, 1182bbxx, a)
+`WAIT
+`WRITES(2013e6, xx10xxa2, 5)
+`WAIT
+`WAIT
+`WAIT
+`READS (2013e5, 1011a2bb, f)
+`READS (2013e7, 23232323, 0)
+
+`DESELECT
+`WAIT
+`WRITES(987135, 8dxxxx1e, 9)
+`WRITES(987137, xxxxxx3f, 1)
+`WRITES(987135, fedcba98, 0) // Should not do anything
+`WRITES(987133, 44xxxxxx, 8)
+`READS (987135, 8d3f441e, f)
diff --git a/tests/interface_wrapper/test.v b/tests/interface_wrapper/test.v
index 4031f35..d69970a 100644
--- a/tests/interface_wrapper/test.v
+++ b/tests/interface_wrapper/test.v
@@ -145,7 +145,7 @@ interface_wrapper wrapper
CLK <= 0;
RST <= 1;
- for (i = 0; i < 600; i++) begin
+ for (i = 0; i < 2000; i++) begin
#1;
CLK <= ~CLK;
@@ -155,9 +155,9 @@ interface_wrapper wrapper
if (M_finished)
$finish;
- end
+ end // for (i = 0; i < 2000; i++)
- $display("error: master hasn't finished its operations in 300 ticks");
+ $display("error: master hasn't finished its operations in 1000 ticks");
$finish;
end
endmodule // interface_wrapper_test