aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/networking.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-06 01:29:26 -0500
committerLeo Famulari <leo@famulari.name>2022-01-06 01:30:27 -0500
commit85f006c8e88f8b7cbe61b62161aec44d03c0e1e1 (patch)
tree2919392308fcd969e05d54ceb63041f169c2839b /gnu/services/networking.scm
parent457416bb1b6aa7b469e6af34f2007c8565f8dd42 (diff)
downloadguix-85f006c8e88f8b7cbe61b62161aec44d03c0e1e1.tar.gz
guix-85f006c8e88f8b7cbe61b62161aec44d03c0e1e1.zip
services: Document the full list of available NTP URLs.
* gnu/services/networking.scm (%ntp-servers): List the URLs granted to us.
Diffstat (limited to 'gnu/services/networking.scm')
-rw-r--r--gnu/services/networking.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/services/networking.scm b/gnu/services/networking.scm
index 77841a18d4..5bb8638930 100644
--- a/gnu/services/networking.scm
+++ b/gnu/services/networking.scm
@@ -427,6 +427,8 @@ daemon is responsible for allocating IP addresses to its client.")))
;; Default set of NTP servers. These URLs are managed by the NTP Pool project.
;; Within Guix, Leo Famulari <leo@famulari.name> is the administrative contact
;; for this NTP pool "zone".
+ ;; The full list of available URLs are 0.guix.pool.ntp.org,
+ ;; 1.guix.pool.ntp.org, 2.guix.pool.ntp.org, and 3.guix.pool.ntp.org.
(list
(ntp-server
(type 'pool)
iv>
+ "1hwww0rcv8sc4k312n4d0jhbyix1jjqgv5djg25bw8127q5iym3s"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; We remove the dependency on statannotations because it
+ ;; will not work with the current version of seaborn. See
+ ;; https://github.com/trevismd/statannotations/issues/122
+ (substitute* "cell2cell/plotting/factor_plot.py"
+ (("from statannotations.Annotator import Annotator")
+ "")
+ (("if statistical_test is not None")
+ "if False"))
+ (substitute* "setup.py"
+ (("'statannotations',") "")
+ ;; We provide version 1.0.4, which should be fine.
+ (("'gseapy == 1.0.3'") "'gseapy'")
+ ;; Using matplotlib 3.5.2 leads to this bug:
+ ;; https://github.com/earmingol/cell2cell/issues/19 but we
+ ;; can't package a different minor version of matplotlib
+ ;; and limit its use to just this package.
+ (("matplotlib >= 3.2.0,<=3.5.1") ""))))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f ;There are no tests
+ #:phases
+ '(modify-phases %standard-phases
+ ;; Numba needs a writable dir to cache functions.
+ (add-before 'build 'set-numba-cache-dir
+ (lambda _ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+ (propagated-inputs
+ (list python-gseapy
+ python-kneed
+ python-matplotlib
+ python-networkx
+ python-numpy
+ python-openpyxl
+ python-pandas
+ python-scikit-learn
+ python-scipy
+ python-seaborn
+ python-statsmodels
+ python-scanpy
+ python-seaborn
+ python-tensorly
+ python-tqdm
+ python-umap-learn
+ python-xlrd))
+ (home-page "https://github.com/earmingol/cell2cell")
+ (synopsis "Python library for cell communication analysis")
+ (description
+ "Cell2cell is a Python library for cell communication analysis.
+This is a method to calculate, visualize and analyze communication between
+cell types. Cell2cell is suitable for single-cell RNA sequencing
+(scRNA-seq) data.")
+ (license license:bsd-3)))
+
(define-public python-cellbender
(package
(name "python-cellbender")
ssors, lookup-compressor): Move it to ... * gnu/compression.scm: ... this new file. * gnu/ci.scm: Adapt it. * local.mk (GNU_SYSTEM_MODULES): Add it. 2022-08-17ci: Fix the images specification.Mathieu Othacehe If the current-guix-package parameter is not set, Cuirass will try to update the in-store Git checkout used by the evaluate.scm inferior: ice-9/boot-9.scm:1685:16: In procedure raise-exception: ERROR: 1. &inferior-exception: arguments: (git-error #<inferior-object #<<git-error> code: -3 message: "could not find repository from '/gnu/store/v33m82qzkvd96dlp2g83dvz62n4pkad2-guix-20d8081'" class: 6>>) inferior: #<inferior pipe (0 1 1) 7f7948957dc0> stack: ((#f ("ice-9/boot-9.scm" 1779 13)) (raise-exception ("ice-9/boot-9.scm" 1682 16)) (raise-exception ("ice-9/boot-9.scm" 1684 16)) (#f ("guix/git.scm" 395 13)) This is a follow-up of: 5bce4c82422de6beb3ce6120ba1592be898c2b72. * gnu/ci.scm (image-jobs): Add source and commit arguments. Use them to set the current-guix-package parameter. (cuirass-jobs): Adapt accordingly. 2022-08-09build-system: Add 'channel-build-system'.Ludovic Courtès * gnu/ci.scm (channel-build-system, channel-source->package): Remove. * gnu/packages/package-management.scm (channel-source->package): New procedure, moved from (gnu ci). * guix/build-system/channel.scm: New file, with code moved from (gnu ci). * doc/guix.texi (Build Systems): Document it. 2022-08-05guix system: Remove unused 'read-operating-system' procedure.Ludovic Courtès * guix/scripts/system.scm (read-operating-system): Remove. * gnu/ci.scm: Remove unused (guix scripts system) import. 2022-05-25Move (gnu platform) and (gnu platforms ...) to guix/.Josselin Poiret * gnu/platform.scm: * gnu/platforms/arm.scm: * gnu/platforms/hurd.scm: * gnu/platforms/mips.scm: * gnu/platforms/powerpc.scm: * gnu/platforms/riscv.scm: * gnu/platforms/s390.scm: * gnu/platforms/x86.scm: Move to guix/. * Makefile.am: * doc/guix.texi (Porting to a New Platform): * etc/release-manifest.scm: * gnu/ci.scm: * gnu/image.scm: * gnu/local.mk: * gnu/packages/bioinformatics.scm: * gnu/packages/bootstrap.scm: * gnu/packages/cross-base.scm: * gnu/packages/instrumentation.scm: * gnu/packages/linux.scm: * gnu/system/image.scm: * gnu/system/images/hurd.scm: * gnu/system/images/novena.scm: * gnu/system/images/pine64.scm: * gnu/system/images/pinebook-pro.scm: * gnu/system/images/rock64.scm: * guix/scripts/build.scm: * guix/scripts/system.scm: * guix/self.scm: Update (gnu platform...) to (guix platform...). Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> 2022-05-22ci: Do not rely on hardcoded cross-targets lists.Mathieu Othacehe * gnu/ci.scm (%cross-targets): Remove it ... (cross-jobs): ... and use the targets procedure instead. * etc/release-manifest.scm: Adapt it. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> 2022-01-01ci: Add extra jobs for tunable packages.Ludovic Courtès This allows us to provide substitutes for tuned package variants. * gnu/ci.scm (package-job): Add #:suffix and honor it. (package->job): Add #:suffix and honor it. (%x86-64-micro-architectures): New variable. (tuned-package-jobs): New procedure. (cuirass-jobs): Add jobs for tunable packages. 2021-12-10Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe 2021-12-06ci: Cross-build the 'guix' package.Ludovic Courtès * gnu/ci.scm (%core-packages): Add GUIX. 2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe 2021-10-04ci: Allow manifests to contain any lowerable object.Ludovic Courtès Previously, manifests could only contain packages: https://lists.gnu.org/archive/html/guix-devel/2021-10/msg00002.html This allows us to pass origins as found in 'etc/source-manifest.scm'. * gnu/ci.scm (derivation->job): Change default #:timeout value to 5h. (manifests->packages): Remove. (manifests->jobs): New procedure. (cuirass-jobs): Use it in the 'manifests' case.