aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorIgor Goryachev <igor@goryachev.org>2024-07-02 09:55:04 +0300
committerAndrew Tropin <andrew@trop.in>2024-07-02 11:53:52 +0400
commitfdfdb15539ff438954f5a2bbc5586861263ada19 (patch)
treec6486f808b3d1cfcc83255a7cade23364a2542c7 /gnu/packages
parent373a635afa15f3d70efa277a9157393421dcb1b9 (diff)
downloadguix-fdfdb15539ff438954f5a2bbc5586861263ada19.tar.gz
guix-fdfdb15539ff438954f5a2bbc5586861263ada19.zip
gnu: elixir-hex: Remove redundant directory, fix lint warnings.
* gnu/packages/elixir.scm (elixir-hex): Remove redundant directory, fix lint warnings. Change-Id: Ic5b29d8ddb9c3d4dc058494cf6cbb5f60a492bb1 Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/elixir.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/elixir.scm b/gnu/packages/elixir.scm
index ace067aa47..e2e9fcc245 100644
--- a/gnu/packages/elixir.scm
+++ b/gnu/packages/elixir.scm
@@ -174,7 +174,7 @@ being successfully used in web development and the embedded software domain.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/hexpm/hex.git")
+ (url "https://github.com/hexpm/hex")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -201,9 +201,14 @@ being successfully used in web development and the embedded software domain.")
(replace 'install
(lambda* (#:key inputs outputs #:allow-other-keys)
(define X.Y #$(version-major+minor (package-version elixir)))
- (define out (string-append (assoc-ref outputs "out") "/lib/elixir/" X.Y "/hex"))
+ (define out (string-append (assoc-ref outputs "out")
+ "/lib/elixir/" X.Y "/hex"))
(mkdir-p out)
- (copy-recursively "_build/prod/lib/hex" out))))))
+ (let* ((prod-dir "_build/prod/lib/hex")
+ (prod-dir-mix (string-append prod-dir "/.mix")))
+ (and (directory-exists? prod-dir-mix)
+ (delete-file-recursively prod-dir-mix))
+ (copy-recursively "_build/prod/lib/hex" out)))))))
(synopsis "Package manager for the Erlang VM")
(description
"This project provides tasks that integrate with Mix, Elixir's build