aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-17 20:10:45 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:25 +0000
commitfd75f170432e8ae3a466aecd0c8e746825ef7e7c (patch)
treeefd1ba2d936e193f80ab4306cd7140eadace8342 /gnu/packages
parente0e883e50afa2c20fab4c00758456dde8c28c297 (diff)
downloadguix-fd75f170432e8ae3a466aecd0c8e746825ef7e7c.tar.gz
guix-fd75f170432e8ae3a466aecd0c8e746825ef7e7c.zip
gnu: python-flask: Update to 3.1.0.
* gnu/packages/python-web.scm (python-flask): Update to 3.1.0. [build-system]: Swapt to pyproject-build-system. [arguments]<phases>: Use default 'check phase. [propagated-inputs]: Add python-blinker. [native-inputs]: Add python-flit-core. Change-Id: Ia745e13a395f2e4d315787600ddc2cbb26308ac7
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm27
1 files changed, 11 insertions, 16 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5a210a0fa7..a338bd9212 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4513,26 +4513,21 @@ minimum of WSGI.")
(define-public python-flask
(package
(name "python-flask")
- (version "2.1.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "Flask" version))
- (sha256
- (base32
- "1j0rjly2yhbm566lq2s8543fs7fz86f77abps539djcfalzbvjd8"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "tests")))))))
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flask" version))
+ (sha256
+ (base32 "1b1nb250jxrjplbs21wnwq69250vs3iz2pdhs7cwi5y8hi8kr1sz"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pytest))
+ (list python-flit-core
+ python-pytest))
(propagated-inputs
(list python-asgiref ;async extra
python-click
+ python-blinker
python-importlib-metadata
python-itsdangerous
python-jinja2