aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-28 23:47:38 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-29 01:07:24 +0100
commitfd0eb4662bb70e676b8aac1d140b888b1d6e08d0 (patch)
tree8eec49d2b7582524e34d53cbc7d91888c71cbb41 /gnu/packages
parent20f19261e4bfdd239b192c3f9beb722970dc67a0 (diff)
downloadguix-fd0eb4662bb70e676b8aac1d140b888b1d6e08d0.tar.gz
guix-fd0eb4662bb70e676b8aac1d140b888b1d6e08d0.zip
gnu: go-1.22: Update to 1.22.6.
* gnu/packages/golang.scm (go-1.22): Update to 1.22.6. Change-Id: I6f2146598b82c251cb31cc7320eef00bbfec6faa
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8b70c564f3..769f658cb3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -951,7 +951,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(package
(inherit go-1.21)
(name "go")
- (version "1.22.5")
+ (version "1.22.6")
(source
(origin
(method git-fetch)
@@ -960,7 +960,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(commit (string-append "go" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1ahcxhyfr4wa4yahpl1jzdr1pizp5xpa6cy96jz649zsp21640d9"))))
+ (base32 "1rjplx7wa6p2c19grx6hhkhn16mmbib5cwmhz9k8ywymlbmhhsyd"))))
(arguments
(substitute-keyword-arguments (package-arguments go-1.21)
((#:phases phases)
@@ -981,9 +981,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(native-inputs
;; Go 1.22 and later requires Go 1.20 (min. 1.20.6, which we don't have)
;; as the bootstrap toolchain.
- (alist-replace "go"
- (list go-1.21)
- (package-native-inputs go-1.21)))))
+ (alist-replace "go" (list go-1.21) (package-native-inputs go-1.21)))))
;;
;; Default Golang version used in guix/build-system/go.scm to build packages.