aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2024-08-20 17:44:10 +0400
committerAndrew Tropin <andrew@trop.in>2024-08-20 17:47:13 +0400
commitfcff2393de20f23c231bd7777ca9c56fb80ec1d7 (patch)
tree80b992d4c0db81039870a2e7ee80ec7ab03b9ef7 /gnu/packages
parent7ed52500c945f5cba8a93dd0df7b89f9bca6b6e7 (diff)
downloadguix-fcff2393de20f23c231bd7777ca9c56fb80ec1d7.tar.gz
guix-fcff2393de20f23c231bd7777ca9c56fb80ec1d7.zip
gnu: libcamera: Enable simple pipeline.
* gnu/packages/networking.scm (libcamera) [arguments]: Enable simple pipeline in configure-flags. Change-Id: Ica9df2a2e224edd85cc32a6f2c66a83d1557f8df
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index ac91e5ee91..b9d5445dfe 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -371,8 +371,6 @@ local filesystem. It splits the file into blocks, hashes them, and compares
them in order to efficiently transfer a minimal amount of data.")
(license (list license:gpl2 license:gpl3))))
-;; This package does not have a release yet.
-;; But this is required to provide a feature in PipeWire.
(define-public libcamera
(package
(name "libcamera")
@@ -395,6 +393,13 @@ them in order to efficiently transfer a minimal amount of data.")
#:configure-flags
#~(list (string-append "-Dbindir="
(assoc-ref %outputs "tools") "/bin")
+
+ ;; In 0.3.1 release simple pipeline wasn't enabled for
+ ;; x86_64 by mistake, it's enabled a couple commits later.
+ ;; Remove this expression on the next release.
+ #$(if (target-x86-64?)
+ "-Dpipelines=ipu3,vimc,uvcvideo,simple"
+ "")
"-Dtest=true" "-Dv4l2=true"
;; XXX: Requires bundled pybind11.
"-Dpycamera=disabled")