aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-06-29 15:11:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-07-05 10:14:30 +0300
commitfc288283d8a8d7e870be83db88930cf441a72045 (patch)
treeb069aa0326fa7c5be1dc3030e735009ddaca6981 /gnu/packages
parent46e465f2d0ae187ca18721c0453c2e2d267742f0 (diff)
downloadguix-fc288283d8a8d7e870be83db88930cf441a72045.tar.gz
guix-fc288283d8a8d7e870be83db88930cf441a72045.zip
gnu: python2-testpath: Remove package.
* gnu/packages/check.scm (python2-testpath): Remove variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm3
1 files changed, 0 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 658905a7f5..55e4cc96ab 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1799,9 +1799,6 @@ and commands. It contains functions to check things on the file system, and
tools for mocking system commands and recording calls to those.")
(license license:expat)))
-(define-public python2-testpath
- (package-with-python2 python-testpath))
-
(define-public python-testlib
(package
(name "python-testlib")
supported-locales'.Ludovic Courtès The list of locales supported by glibc is now built from source. * gnu/installer/locale.scm (locale-string->locale): Add optional 'codeset' parameter and honor it. (supported-locales->locales): Rewrite to 'read' from SUPPORTED-LOCALES. * gnu/installer.scm (compute-locale-step): Pass the result of 'glibc-supported-locales' instead of the "aux-files/SUPPORTED" file. * gnu/installer/aux-files/SUPPORTED: Remove. * gnu/local.mk (dist_installer_DATA): Remove it. 2019-04-26installer: Actually reboot when the user presses "Reboot."Ludovic Courtès * gnu/installer/newt/final.scm (run-install-success-page): Return 'success. * gnu/installer.scm (installer-program): Check the result of the 'final step and reboot upon success. 2019-04-26installer: Run wrapped program with 'execl', not 'system'.Ludovic Courtès 'system' invokes /bin/sh, which is certainly not needed here. * gnu/installer.scm (installer-program): Use 'execl', not 'system'. 2019-04-17installer: Translate keyboard layout names.Ludovic Courtès * gnu/installer.scm (installer-program)[installer-builder]: Call 'bindtextdomain' for "xkeyboard-config". * gnu/installer/newt/keymap.scm (run-keymap-page): Add calls to 'gettext'. 2019-04-17installer: Display language and territory names natively.Ludovic Courtès * gnu/installer.scm (installer-program): Add calls to 'bindtextdomain'. * gnu/installer/newt/locale.scm (run-locale-page) <language, territory>: Add calls to 'gettext'. 2019-04-12installer: Choosing a locale opens the translated manual on tty2.Ludovic Courtès Suggested by Florian Pelz. * gnu/system/install.scm (%installation-node-names): New variable. (log-to-info): Expect the chosen locale as an argument. Compute the language, Info file name, and node name. Install the locale. (documentation-shepherd-service): Add 'locale' parameter to the 'start' action and honor it. Set GUIX_LOCPATH and TERM as environment variables for the process. * gnu/installer.scm (apply-locale): Use (gnu services herd). Call 'stop-service' and 'start-service' with the chosen locale. 2019-04-07installer: Generalize desktop environments to system services.Ludovic Courtès * gnu/installer/services.scm (<desktop-environment>): Rename to... (<system-service>): ... this. Add a 'type' field. (%desktop-environments): Rename to... (%system-services): ... this. (desktop-system-service?): New procedure. (desktop-environments->configuration): Rename to... (system-services->configuration): ... this. Determine the base list of services based on whether SERVICES contains at least one "desktop" service. * gnu/installer/newt/services.scm (run-desktop-environments-cbt-page): Adjust accordingly. * gnu/installer.scm (installer-steps): Likewise. 2019-04-07installer: Move the 'locale' step before the 'welcome' step.Ludovic Courtès * gnu/installer.scm (installer-steps): Move the 'locale step before 'welcome. 2019-03-27installer: Produce an 'initrd-modules' field if needed.Ludovic Courtès * gnu/installer/parted.scm (root-user-partition?): New procedure. (bootloader-configuration): Use it. (user-partition-missing-modules, initrd-configuration): New procedures. (user-partitions->configuration): Call 'initrd-configuration'.o * gnu/installer.scm (not-config?): Rename to... (module-to-import?): ... this. Add cases to exclude non-installer and non-build (gnu …) modules. (installer-program)[installer-builder]: Add GUIX to the extension list. 2019-03-25installer: Set the system's 'keyboard-layout' field.Ludovic Courtès * gnu/installer/newt/keymap.scm (keyboard-layout->configuration): New procedure. * gnu/installer.scm (compute-keymap-step): Return RESULT. (installer-steps) <'keymap>: Add 'configuration-formatter' field. (installer-program): Use (gnu installer newt keymap). * gnu/installer/parted.scm (bootloader-configuration): Set 'keyboard-layout'.