aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-24 16:15:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:39 +0300
commitfb06a020a009f7facb3d2b35ca91d0611ef6b450 (patch)
treeada33575becf5a2c16390ab1082e9bbdcd0acd0c /gnu/packages
parent4e4fca901f36a6ae729a36d4d5b8abdc4a018321 (diff)
downloadguix-fb06a020a009f7facb3d2b35ca91d0611ef6b450.tar.gz
guix-fb06a020a009f7facb3d2b35ca91d0611ef6b450.zip
gnu: Add rust-redox-syscall-0.3.
* gnu/packages/crates-io.scm (rust-redox-syscall-0.3): New variable. (rust-redox-syscall-0.2): Inherit from rust-redox-syscall-0.3.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm31
1 files changed, 24 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index affa34251e..b1815a61a6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49216,9 +49216,32 @@ currently pressed on macOS.")
owned memory.")
(license license:expat)))
+(define-public rust-redox-syscall-0.3
+ (package
+ (name "rust-redox-syscall")
+ (version "0.3.5")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "redox-syscall" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0acgiy2lc1m2vr8cr33l5s7k9wzby8dybyab1a9p753hcbr68xjn"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1))))
+ (home-page "https://gitlab.redox-os.org/redox-os/syscall")
+ (synopsis "Rust library to access raw Redox system calls")
+ (description
+ "This package provides a Rust library to access raw Redox system calls.")
+ (license license:expat)))
(define-public rust-redox-syscall-0.2
(package
+ (inherit rust-redox-syscall-0.3)
(name "rust-redox-syscall")
(version "0.2.10")
(source
@@ -49228,16 +49251,10 @@ owned memory.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1zq36bhw4c6xig340ja1jmr36iy0d3djp8smsabxx71676bg70w3"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
- (("rust-bitflags" ,rust-bitflags-1))))
- (home-page "https://gitlab.redox-os.org/redox-os/syscall")
- (synopsis "Rust library to access raw Redox system calls")
- (description
- "This package provides a Rust library to access raw Redox system calls.")
- (license license:expat)))
+ (("rust-bitflags" ,rust-bitflags-1))))))
;; This package requires features which are unavailable
;; on the stable releases of Rust.