aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-15 20:33:38 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:49 +0000
commitfaea1bad5f5f6b1097aab54d57b620a3ce9d3ae3 (patch)
tree99655544212694f9af737c724d4f26c8a27e1a90 /gnu/packages
parent1d4c7fefd2567b74c66a381487a8d869fc6f4c25 (diff)
downloadguix-faea1bad5f5f6b1097aab54d57b620a3ce9d3ae3.tar.gz
guix-faea1bad5f5f6b1097aab54d57b620a3ce9d3ae3.zip
gnu: Add go-github-com-hashicorp-go-immutable-radix.
* gnu/packages/golang-xyz.scm (go-github-com-hashicorp-go-immutable-radix, go-github-com-hashicorp-go-immutable-radix-v2): New variables. Change-Id: I2c5ed0acdaec49e91720ba71efd45e849855cb2b
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0e5adb80da..a3485cee35 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3560,6 +3560,59 @@ a command-line program @code{hclogvet} that can be used to check that the loggin
methods on @code{hclog.Logger} are used correctly.")
(license license:expat)))
+(define-public go-github-com-hashicorp-go-immutable-radix
+ (package
+ (name "go-github-com-hashicorp-go-immutable-radix")
+ (version "1.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/go-immutable-radix")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s7sf8y5lj8rx4gdymrz29gg6y2xwksfpgniaz32yzcmg3c817zb"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/go-immutable-radix"))
+ (propagated-inputs
+ (list go-github-com-hashicorp-golang-lru
+ go-github-com-hashicorp-go-uuid))
+ (home-page "https://github.com/hashicorp/go-immutable-radix")
+ (synopsis "Immutable radix tree implementation in Golang")
+ (description
+ "This package implements an immutable
+@url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}. It only provides a
+single @code{Tree} implementation, optimized for sparse nodes.")
+ (license license:mpl2.0)))
+
+(define-public go-github-com-hashicorp-go-immutable-radix-v2
+ (package
+ (inherit go-github-com-hashicorp-go-immutable-radix)
+ (name "go-github-com-hashicorp-go-immutable-radix-v2")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/go-immutable-radix")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sik2rg6xldk87aqzx9dmpg4f2cwkk7ypdwsjqq131npx7jszxzr"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/go-immutable-radix/v2"))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs
+ go-github-com-hashicorp-go-immutable-radix)
+ (prepend go-golang-org-x-exp)
+ (replace "go-github-com-hashicorp-golang-lru"
+ go-github-com-hashicorp-golang-lru-v2)))))
+
(define-public go-github-com-hashicorp-go-multierror
(package
(name "go-github-com-hashicorp-go-multierror")