aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-10 21:39:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-11 01:03:21 +0100
commitfa6cc510ea5336f6be370edfc76a19d6519756cb (patch)
tree435f2dbf076b66f7519cbb5f9ecff08a37efa4bc /gnu/packages
parent490c6d4b034c962f7d47cf8fd342509289743b7a (diff)
downloadguix-fa6cc510ea5336f6be370edfc76a19d6519756cb.tar.gz
guix-fa6cc510ea5336f6be370edfc76a19d6519756cb.zip
gnu: Add r-pkgdown.
* gnu/packages/cran.scm (r-pkgdown): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4082644bbf..a2ddea2906 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -26714,3 +26714,49 @@ designed for the needs of RMarkdown packages like @code{pkgdown},
to their documentation on the web, and automatic translation of ANSI escapes
in output to the equivalent HTML.")
(license license:expat)))
+
+(define-public r-pkgdown
+ (package
+ (name "r-pkgdown")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "pkgdown" version))
+ (sha256
+ (base32
+ "1k31biyvxkv3xjc1yy3nzb9wfza3vbx97fv17nly5a6vlv7zqbs4"))))
+ (properties `((upstream-name . "pkgdown")))
+ (build-system r-build-system)
+ (inputs `(("pandoc" ,pandoc)))
+ (propagated-inputs
+ `(("r-callr" ,r-callr)
+ ("r-crayon" ,r-crayon)
+ ("r-desc" ,r-desc)
+ ("r-digest" ,r-digest)
+ ("r-downlit" ,r-downlit)
+ ("r-fs" ,r-fs)
+ ("r-httr" ,r-httr)
+ ("r-magrittr" ,r-magrittr)
+ ("r-memoise" ,r-memoise)
+ ("r-openssl" ,r-openssl)
+ ("r-purrr" ,r-purrr)
+ ("r-ragg" ,r-ragg)
+ ("r-rematch2" ,r-rematch2)
+ ("r-rlang" ,r-rlang)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-tibble" ,r-tibble)
+ ("r-whisker" ,r-whisker)
+ ("r-withr" ,r-withr)
+ ("r-xml2" ,r-xml2)
+ ("r-yaml" ,r-yaml)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://pkgdown.r-lib.org")
+ (synopsis "Make static HTML documentation for an R package")
+ (description
+ "The goal of this package is to generate an attractive and useful website
+from a source package. @code{pkgdown} converts your documentation, vignettes,
+README file, and more to HTML making it easy to share information about your
+package online.")
+ (license license:expat)))