aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-10-30 15:50:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-09 12:12:25 +0100
commitfa51705f19a6190f81a0b479871864b9f055cef8 (patch)
tree8db0453c2b3c334f3cbbefdfb3cdb13e5f690baf /gnu/packages
parentc47a8cd9e1a0ade649853e9344dbd7881830c9e5 (diff)
downloadguix-fa51705f19a6190f81a0b479871864b9f055cef8.tar.gz
guix-fa51705f19a6190f81a0b479871864b9f055cef8.zip
gnu: r-a4classif: Update to 1.38.0.
* gnu/packages/bioconductor.scm (r-a4classif): Update to 1.38.0.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 4edc615c6c..ac19230b9d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4055,24 +4055,26 @@ arrays.")
(define-public r-a4classif
(package
(name "r-a4classif")
- (version "1.36.0")
+ (version "1.38.0")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "a4Classif" version))
(sha256
(base32
- "0bj8m4nprw3maahd1qx9jjdxfip9ihbbpydbzwjxn6dlgw2i8mcr"))))
+ "03fln0x1am5fqhj4fpkx1yq58paqha086bhhr8az8j0vsq1r7wcz"))))
(properties `((upstream-name . "a4Classif")))
(build-system r-build-system)
(propagated-inputs
`(("r-a4core" ,r-a4core)
("r-a4preproc" ,r-a4preproc)
+ ("r-biobase" ,r-biobase)
("r-glmnet" ,r-glmnet)
- ("r-mlinterfaces" ,r-mlinterfaces)
("r-pamr" ,r-pamr)
("r-rocr" ,r-rocr)
("r-varselrf" ,r-varselrf)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://bioconductor.org/packages/a4Classif/")
(synopsis "Automated Affymetrix array analysis classification package")
(description
"-DUSE_GTK4=ON" ;; The minibrowser, not built by default, is a good ;; tool to validate the good operation of ;; webkitgtk. "-DENABLE_MINIBROWSER=ON" "-DUSE_LIBBACKTRACE=OFF" ; XXX: circular dependency ;; The default lib installation prefix is lib64. (string-append "-DLIB_INSTALL_DIR=" #$output "/lib") ;; XXX: WebKitGTK makes use of elogind's systemd-compatible ;; headers, which are under the include/elogind prefix. The WTF ;; component doesn't propagate the Journald header correctly ;; detected (stubs from elogind), hence the following hack (see: ;; https://bugs.webkit.org/show_bug.cgi?id=254495). (string-append "-DCMAKE_CXX_FLAGS=-I" (search-input-directory %build-inputs "include/elogind"))) ;; The build may fail with -j1 (see: ;; https://bugs.webkit.org/show_bug.cgi?id=195251). #:make-flags #~(list "-j" (number->string (max 2 (parallel-job-count)))) #:phases #~(modify-phases %standard-phases (add-before 'build 'set-CC (lambda _ ;; Some Perl scripts check for the CC environment variable, else ;; use /usr/bin/gcc. (setenv "CC" #$(cc-for-target)))) (add-after 'unpack 'configure-bubblewrap-store-directory (lambda _ ;; This phase works in tandem with ;; webkitgtk-adjust-bubblewrap-paths.patch and avoids hard ;; coding /gnu/store, for users with other prefixes. (let ((store-directory (%store-directory))) (substitute* "Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp" (("@storedir@") store-directory))))) (add-after 'unpack 'do-not-disable-new-dtags ;; Ensure the linker uses new dynamic tags as this is what Guix ;; uses and validates in the validate-runpath phase. (lambda _ (substitute* "Source/cmake/OptionsCommon.cmake" (("if \\(LD_SUPPORTS_DISABLE_NEW_DTAGS\\)") "if (FALSE)")))) (add-after 'unpack 'embed-absolute-wpebackend-reference (lambda* (#:key inputs #:allow-other-keys) (let ((wpebackend-fdo (assoc-ref inputs "wpebackend-fdo"))) (substitute* "Source/WebKit/UIProcess/glib/WebProcessPoolGLib.cpp" (("libWPEBackend-fdo-[\\.0-9]+\\.so" all) (search-input-file inputs (string-append "lib/" all))))))) #$@(if (target-x86-32?) ;; Don't include x86intrin.h on i686-linux. '((add-after 'unpack 'fix-headers (lambda _ (substitute* "Source/ThirdParty/ANGLE/src/common/platform.h" (("\\|\\| defined\\(__i386__\\)") ""))))) '()) #$@(if (target-x86-64?) '() '((add-after 'unpack 'disable-sse2 (lambda _ (substitute* "Source/cmake/WebKitCompilerFlags.cmake" (("WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING") "FALSE")))))) (add-after 'install 'move-doc-files (lambda* (#:key outputs #:allow-other-keys) (let ((doc (assoc-ref outputs "doc"))) (mkdir-p (string-append doc "/share")) (rename-file (string-append #$output "/share/doc") (string-append doc "/share/doc")))))))) (native-inputs (list bison gettext-minimal `(,glib "bin") ;for glib-mkenums, etc. gobject-introspection gperf perl pkg-config python-wrapper gi-docgen ruby-2.7 unifdef)) (propagated-inputs (list gtk libsoup)) (inputs (list at-spi2-core bubblewrap elogind enchant geoclue gst-plugins-base gst-plugins-bad-minimal harfbuzz hyphen icu4c lcms libavif libgcrypt libgudev libjpeg-turbo libjxl libmanette libpng libseccomp libsecret libtasn1 libwebp libwpe libxcomposite libxml2 libxslt libxt mesa openjpeg sqlite woff2 wpebackend-fdo xdg-dbus-proxy)) (properties '((timeout . 144000))) ; 40 hours, most notably for aarch64 (home-page "https://www.webkitgtk.org/") (synopsis "Web content engine for GTK+") (description "WebKitGTK+ is a full-featured port of the WebKit rendering engine, suitable for projects requiring any kind of web integration, from hybrid HTML/CSS applications to full-fledged web browsers. WebKitGTK+ video playing capabilities can be extended through the use of GStreamer plugins (not propagated by default) such as @code{gst-plugins-good} and @code{gst-plugins-bad}.") ;; WebKit's JavaScriptCore and WebCore components are available under ;; the GNU LGPL, while the rest is available under a BSD-style license. (license (list license:lgpl2.0 license:lgpl2.1+ license:bsd-2 license:bsd-3)))) (define-public webkitgtk-for-gtk3 (package (inherit webkitgtk) (name "webkitgtk-for-gtk3") (arguments (substitute-keyword-arguments (package-arguments webkitgtk) ((#:configure-flags flags) #~(cons* "-DUSE_GTK4=OFF" (delete "-DUSE_GTK4=ON" #$flags))))) (propagated-inputs (modify-inputs (package-propagated-inputs webkitgtk) (replace "gtk" gtk+))) (inputs (modify-inputs (package-inputs webkitgtk) (prepend libnotify))))) ;;; Required by e.g. emacs-next-pgtk, emacs-xwidgets, and some other GNOME ;;; packages for webkit2gtk-4.0. See also the upstream tracker for libsoup 3: ;;; https://gitlab.gnome.org/GNOME/libsoup/-/issues/218. (define-public webkitgtk-with-libsoup2 (package/inherit webkitgtk-for-gtk3 (name "webkitgtk-with-libsoup2") (arguments (substitute-keyword-arguments (package-arguments webkitgtk-for-gtk3) ((#:configure-flags flags) #~(cons "-DUSE_SOUP2=ON" #$flags)))) (propagated-inputs (modify-inputs (package-propagated-inputs webkitgtk-for-gtk3) (replace "libsoup" libsoup-minimal-2))))) (define-public wpewebkit (package (inherit webkitgtk) (name "wpewebkit") (version "2.44.1") (source (origin (inherit (package-source webkitgtk)) (uri (string-append "https://wpewebkit.org/releases/" name "-" version ".tar.xz")) (sha256 (base32 "16y1gdz38d4b99b8zrvxy0nbrc70ih02ngi8090x7148rx7vz7rc")))) (arguments (substitute-keyword-arguments (package-arguments webkitgtk) ((#:configure-flags flags) #~(cons "-DPORT=WPE" (delete "-DPORT=GTK" #$flags))))) (synopsis "WebKit port optimized for embedded devices") (description "WPE WebKit allows embedders to create simple and performant systems based on Web platform technologies. It is designed with hardware acceleration in mind, leveraging common 3D graphics APIs for best performance.") (home-page "https://wpewebkit.org/") (properties '((cpe-name . "wpe_webkit")))))