aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 12:18:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 12:18:56 +0200
commitfa4867b53da1ed5541214dfdac9eb2a11155aa73 (patch)
tree276b40df83417fcb6fbfa21f46d773de9fc29c19 /gnu/packages
parent1e4e87d6e90e9d63820714c846b5e0f7b6e5315a (diff)
downloadguix-fa4867b53da1ed5541214dfdac9eb2a11155aa73.tar.gz
guix-fa4867b53da1ed5541214dfdac9eb2a11155aa73.zip
gnu: Add texlive-ptex.
* gnu/packages/tex.scm (texlive-ptex): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2b3736513d..1a4adcae9b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13430,6 +13430,47 @@ not overly complex, so that users should find it easy to adapt the macros to
their specific needs.")
(license license:lppl)))
+(define-public texlive-ptex
+ (package
+ (name "texlive-ptex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/eptex.1"
+ "doc/man/man1/eptex.man1.pdf"
+ "doc/man/man1/makejvf.1"
+ "doc/man/man1/makejvf.man1.pdf"
+ "doc/man/man1/mendex.1"
+ "doc/man/man1/mendex.man1.pdf"
+ "doc/man/man1/pbibtex.1"
+ "doc/man/man1/pbibtex.man1.pdf"
+ "doc/man/man1/ppltotf.1"
+ "doc/man/man1/ppltotf.man1.pdf"
+ "doc/man/man1/ptex.1"
+ "doc/man/man1/ptex.man1.pdf"
+ "doc/man/man1/ptftopl.1"
+ "doc/man/man1/ptftopl.man1.pdf")
+ (base32
+ "1dk8rvadr1q00bjizj567lzjp5l47pr7miyk0ghkajbiiwbqi0kn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:create-formats #~(list "eptex" "ptex")))
+ (propagated-inputs
+ (list texlive-cm
+ texlive-etex
+ texlive-hyphen-base
+ texlive-knuth-lib
+ texlive-plain
+ texlive-ptex-base
+ texlive-ptex-fonts))
+ (home-page "https://ctan.org/pkg/ptex")
+ (synopsis "TeX system for publishing in Japanese")
+ (description
+ "pTeX adds features related to vertical writing, and deals with other
+problems in typesetting Japanese. A manual (in both Japanese and English) is
+distributed as package @code{pTeX-manual}.")
+ (license license:bsd-3)))
+
(define-public texlive-pwebmac
(package
(name "texlive-pwebmac")