aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-07-07 01:19:17 -0400
committerMark H Weaver <mhw@netris.org>2014-07-07 17:17:18 -0400
commitfa40e4d4ec92222fa68cb9694812a310344cc4f0 (patch)
tree25da6d4853211e7c4438dd79829a016a3afa4795 /gnu/packages
parent59c51be2900b896d87b2393faecfef732d015e34 (diff)
downloadguix-fa40e4d4ec92222fa68cb9694812a310344cc4f0.tar.gz
guix-fa40e4d4ec92222fa68cb9694812a310344cc4f0.zip
gnu: bitlbee: Upgrade to 3.2.2.
* gnu/packages/messaging.scm (bitlbee): Upgrade to 3.2.2. Remove patches. Use 'libotr' instead of 'libotr-3'. * gnu/packages/patches/bitlbee-fix-tests.patch: Remove file. * gnu/packages/patches/bitlbee-memset-fix.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove patches.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/messaging.scm8
-rw-r--r--gnu/packages/patches/bitlbee-fix-tests.patch33
-rw-r--r--gnu/packages/patches/bitlbee-memset-fix.patch15
3 files changed, 3 insertions, 53 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index c1a755ef84..7e2056c347 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -77,20 +77,18 @@ providing:
(define-public bitlbee
(package
(name "bitlbee")
- (version "3.2.1")
+ (version "3.2.2")
(source (origin
(method url-fetch)
(uri (string-append "http://get.bitlbee.org/src/bitlbee-"
version ".tar.gz"))
(sha256
- (base32 "0n8g5452i5qap43zxb83gxp01d48psf6rr3k1q7z6a3dgpfi3x00"))
- (patches (list (search-patch "bitlbee-memset-fix.patch")
- (search-patch "bitlbee-fix-tests.patch")))))
+ (base32 "13jmcxxgli82wb2n4hs091159xk8rgh7nb02f478lgpjh6996f5s"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("check" ,check)))
(inputs `(("glib" ,glib)
- ("libotr" ,libotr-3)
+ ("libotr" ,libotr)
("gnutls" ,gnutls)
("zlib" ,zlib) ; Needed to satisfy "pkg-config --exists gnutls"
("python" ,python-2)
diff --git a/gnu/packages/patches/bitlbee-fix-tests.patch b/gnu/packages/patches/bitlbee-fix-tests.patch
deleted file mode 100644
index 52bb6c605d..0000000000
--- a/gnu/packages/patches/bitlbee-fix-tests.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Pass the correct number of arguments to 'nick_strip' and 'nick_ok' in tests.
-
-Patch by Mark H Weaver <mhw@netris.org>.
-
---- bitlbee/tests/check_nick.c.orig 2013-11-27 17:54:54.000000000 -0500
-+++ bitlbee/tests/check_nick.c 2014-03-05 23:41:45.761230468 -0500
-@@ -30,7 +30,7 @@ START_TEST(test_nick_strip)
- for (i = 0; get[i]; i++) {
- char copy[60];
- strcpy(copy, get[i]);
-- nick_strip(copy);
-+ nick_strip(NULL, copy);
- fail_unless (strcmp(copy, expected[i]) == 0,
- "(%d) nick_strip broken: %s -> %s (expected: %s)",
- i, get[i], copy, expected[i]);
-@@ -45,7 +45,7 @@ START_TEST(test_nick_ok_ok)
- int i;
-
- for (i = 0; nicks[i]; i++) {
-- fail_unless (nick_ok(nicks[i]) == 1,
-+ fail_unless (nick_ok(NULL, nicks[i]) == 1,
- "nick_ok() failed: %s", nicks[i]);
- }
- }
-@@ -58,7 +58,7 @@ START_TEST(test_nick_ok_notok)
- int i;
-
- for (i = 0; nicks[i]; i++) {
-- fail_unless (nick_ok(nicks[i]) == 0,
-+ fail_unless (nick_ok(NULL, nicks[i]) == 0,
- "nick_ok() succeeded for invalid: %s", nicks[i]);
- }
- }
diff --git a/gnu/packages/patches/bitlbee-memset-fix.patch b/gnu/packages/patches/bitlbee-memset-fix.patch
deleted file mode 100644
index 1d801e0070..0000000000
--- a/gnu/packages/patches/bitlbee-memset-fix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Fix the size argument to 'memset'.
-
-Patch by Mark H Weaver <mhw@netris.org>.
-
---- bitlbee/lib/md5.c.orig 2013-11-27 17:54:54.000000000 -0500
-+++ bitlbee/lib/md5.c 2014-03-05 21:39:04.739746093 -0500
-@@ -159,7 +159,7 @@ void md5_finish(struct MD5Context *ctx,
- ctx->buf[2] = cvt32(ctx->buf[2]);
- ctx->buf[3] = cvt32(ctx->buf[3]);
- memcpy(digest, ctx->buf, 16);
-- memset(ctx, 0, sizeof(ctx)); /* In case it's sensitive */
-+ memset(ctx, 0, sizeof(*ctx)); /* In case it's sensitive */
- }
-
- void md5_finish_ascii(struct MD5Context *context, char *ascii)