aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-06-02 22:51:13 +0800
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:03 +0200
commitf876b54a21568427b7896aef5c4b0fdd1009fe71 (patch)
treeaa2a0c5fc2caeef453b68da43944e80c4caadcc7 /gnu/packages
parentd35ccf0899f972d03fa954e88bc3a1ec3f9cc3d0 (diff)
downloadguix-f876b54a21568427b7896aef5c4b0fdd1009fe71.tar.gz
guix-f876b54a21568427b7896aef5c4b0fdd1009fe71.zip
gnu: libinput: Update to 1.23.0.
* gnu/packages/freedesktop.scm (libinput): Update to 1.23.0. [native-inputs]: Add python-minimal-wrapper and python-pytest. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Change-Id: I207898dc6971e9fa7be24b7ba9c8fc1887ec930e
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/freedesktop.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index f15c9d82dd..bfaa45361a 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -704,7 +704,7 @@ freedesktop.org project.")
;; Updating this will rebuild over 700 packages through libinput-minimal.
(package
(name "libinput")
- (version "1.22.1")
+ (version "1.23.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -712,7 +712,7 @@ freedesktop.org project.")
(commit version)))
(sha256
(base32
- "17a5qlym2d6lg2j8fdpxda9k7x5zr35flb4wlj1bz7h0mnkh8326"))))
+ "0wnqfnxxvf9jclh64hrb0scn3s1dmwdkmqf7hp0cfmjz5n5nnv7d"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Ddocumentation=false")
@@ -722,7 +722,7 @@ freedesktop.org project.")
;; Meson target anyway.
#:build-type "release"))
(native-inputs
- (append (list check pkg-config)
+ (append (list check pkg-config python-minimal-wrapper python-pytest)
(if (%current-target-system)
(list pkg-config-for-build)
'())))