aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-06-04 17:42:09 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-22 13:13:15 +0100
commitf7f26611bfa0c30b35c3feba86961c8c5e81583b (patch)
treec625188965599f95986391153b24c3789a106afa /gnu/packages
parent4026402553b9fb0418960ad5e67f6c6a90c6c2f1 (diff)
downloadguix-f7f26611bfa0c30b35c3feba86961c8c5e81583b.tar.gz
guix-f7f26611bfa0c30b35c3feba86961c8c5e81583b.zip
gnu: Add perl-constant.
* gnu/packages/perl.scm (perl-constant): New variable. Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3cd2a34d3d..38888b63e5 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2210,6 +2210,28 @@ configuration files.")
scalars, arrays, and hashes.")
(license (package-license perl))))
+(define-public perl-constant
+ (package
+ (name "perl-constant")
+ (version "1.33")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/constant-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "015my616h5l2fswh52x4dp3n007gk5lax83ww9q6cmzb610mv5kr"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/constant")
+ (synopsis "Perl pragma to declare constants")
+ (description
+ "This pragma allows you to declare constants at compile-time. When a
+constant is used in an expression, Perl replaces it with its value at compile
+time, and may then optimize the expression further. In particular, any code
+in an @code{if (CONSTANT)} block will be optimized away if the constant is
+false.")
+ (license license:perl-license)))
+
(define-public perl-context-preserve
(package
(name "perl-context-preserve")