aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-27 22:36:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-13 16:44:58 +0200
commitf79e4b1fcd2bf082610e868fbd4c9e5c505c9f49 (patch)
treeb5bc2e864858819b73d57b5b2a7def07c1b176ae /gnu/packages
parentc7891956cdccfb5ecd2c4770e9b7e04bcff5d861 (diff)
downloadguix-f79e4b1fcd2bf082610e868fbd4c9e5c505c9f49.tar.gz
guix-f79e4b1fcd2bf082610e868fbd4c9e5c505c9f49.zip
gnu: ghc-http: Prevent embedding of spurious references.
* gnu/packages/haskell-web.scm (ghc-http)[arguments]: Add build phase "create-simple-paths-module" to avoid retaining unnecessary references.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-web.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 5931fcaea5..b9474c973a 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -197,7 +197,23 @@ both client and server code).")
("ghc-network-uri" ,ghc-network-uri)
("ghc-split" ,ghc-split)))
(arguments
- `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
+ `(#:tests? #f ; FIXME: currently missing libraries used for tests.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'create-simple-paths-module
+ (lambda _
+ (call-with-output-file "Paths_HTTP.hs"
+ (lambda (port)
+ (format port "\
+{-# LANGUAGE CPP #-}
+{-# LANGUAGE NoRebindableSyntax #-}
+{-# OPTIONS_GHC -fno-warn-missing-import-lists #-}
+module Paths_HTTP (version) where
+import Data.Version (Version(..))
+version :: Version
+version = Version [~a] []
+" (string-map (lambda (chr) (if (eq? chr #\.) #\, chr)) ,version))))
+ #t)))))
(home-page "https://github.com/haskell/HTTP")
(synopsis "Library for client-side HTTP")
(description
Use system libHaru....* gnu/packages/image-processing.scm (vtk)[snippet]: Delete bundled libHaru and patch VTK for newer libHaru. Reindent and remove trailing boolean. [arguments]: Specify external libHaru in configure flags. [inputs]: Add libharu. Signed-off-by: Christopher Baines <mail@cbaines.net> Paul A. Patience 2022-09-11gnu: vtk: Build against proj-7....* gnu/packages/image-processing.scm (vtk)[inputs]: Replace proj with proj-7. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Felix Gruber 2022-08-30gnu: opencv: Build Python bindings....* gnu/packages/image-processing.scm (opencv)[arguments]: Change variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Tomasz Jeneralczyk 2022-08-11gnu: vtk: Enable the RenderingExternal module....* gnu/packages/image-processing.scm (vtk)[arguments]<#:configure-flags>: Add -DVTK_MODULE_ENABLE_VTK_RenderingExternal=YES. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Paul A. Patience 2022-07-31gnu: qttools: Rename to qttools-5....Automated with: git grep -l qttools | xargs sed 's/\bqttools\b/\0-5/g' -i git checkout NEWS Maxim Cournoyer 2022-07-31gnu: qtdeclarative: Rename to qtdeclarative-5....Automated via the following commands: git grep -l '\bqtdeclarative\b' | xargs sed -E 's/qtdeclarative/\0-5/g' -i git checkout NEWS Maxim Cournoyer 2022-07-31gnu: qtsvg: Rename variable to qtsvg-5....This is in preparation of the qtsvg update to version 6. This change was automated via the following command: git grep -l '\bqtsvg\b' | xargs sed 's/qtsvg/qtsvg-5/g' -i Maxim Cournoyer 2022-07-07gnu: mia: Build against VTK 9....* gnu/packages/image-processing.scm (mia): Build against VTK 9. [inputs]: Remove vtk-7; add vtk. [source]: Add mia-vtk9.patch. * gnu/packages/patches/mia-vtk9.patch: New file. * gnu/local.mk: Add it. Signed-off-by: Christopher Baines <mail@cbaines.net> Felix Gruber 2022-06-05gnu: vtk@7: Simplify regular expression....* gnu/packages/image-processing.scm (vtk-7)[arguments]: Replace ‘.’ wildcards with literal ‘@’ character matches. Tobias Geerinckx-Rice 2022-06-09gnu: vtk@7: Do not embed running kernel version....* gnu/packages/image-processing.scm (vtk-7)[arguments]: Add 'remove-kernel-version phase. Vagrant Cascadian 2022-05-31gnu: mia: Update to 2.4.7....* gnu/packages/patches/mia-fix-boost-headers.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/image-processing.scm (mia): Update to 2.4.7. [source]: Apply patch. [configure-flags]: Use the more conventional OFF option value (instead of 0). [inputs]: Use new style. Replace python2-lxml by python-lxml. Replace vtk by vtk-7. [native-inputs]: Use new style. Replace python-2 with python-wrapper. Maxim Cournoyer 2022-05-31gnu: dcmtk: Update to 3.6.7 and build as a shared library....* gnu/packages/image-processing.scm (dcmtk): Update to 3.6.7. [arguments]: New field. Maxim Cournoyer 2022-05-31gnu: Remove vtk-6....* gnu/packages/image-processing.scm (vtk-6): Delete variable. Maxim Cournoyer 2022-05-31gnu: itk-snap: Fix build....* gnu/packages/patches/itk-snap-alt-glibc-compat.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/image-processing.scm (itk-snap): Apply it. [phases]: Delete trailing #t. [inputs]: Use new style. Replace vtk-6 with vtk-7. Maxim Cournoyer 2022-05-31gnu: Add vtk-7....* gnu/packages/image-processing.scm: (vtk-7): New variable. * gnu/packages/patches/vtk-7-gcc-10-compat.patch: New patch. * gnu/packages/patches/vtk-7-hdf5-compat.patch: Likewise. * gnu/packages/patches/vtk-7-python-compat.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them. Maxim Cournoyer 2022-04-26gnu: Add bart....* gnu/packages/image-processing.scm (bart): New variable. Ricardo Wurmus 2022-04-01gnu: vtk: Remove input labels....* gnu/packages/image-processing.scm (vtk)[inputs]: Remove labels. Ludovic Courtès 2022-04-01gnu: vtk@6: Depend on Python 2.x, not 3.x....* gnu/packages/image-processing.scm (vtk-6)[native-inputs]: Replace PYTHON with PYTHON-2. Ludovic Courtès 2022-03-22gnu: opencv: Add pkgconfig generation flag....* gnu/packages/image-processing.scm (opencv)[arguments]: Add OPENCV_GENERATE_PKGCONFIG flag. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Blake Shaw