aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:24:43 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:07 +0200
commitf782bf4a4024faeb138a6be6584a9af6d4482689 (patch)
treecdd533a48f72982d42718f457b6c23be1a05a05e /gnu/packages
parent7896c19c1cc2ca3121b3c1ee9c544890c569692c (diff)
downloadguix-f782bf4a4024faeb138a6be6584a9af6d4482689.tar.gz
guix-f782bf4a4024faeb138a6be6584a9af6d4482689.zip
gnu: emacs-idle-highlight: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-idle-highlight)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e73b20c703..eef9006587 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6316,14 +6316,13 @@ number on the left margin in Emacs.")
(version "1.1.3")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/nonsequitur/idle-highlight-mode/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nonsequitur/idle-highlight-mode.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0kdv10hrgqpskjh0zvpnzwlkn5bccnqxas62gkws6njln57bf8nl"))))
+ (base32 "0x4w1ksrw7dicl84zpf4d4scg672dyan9g95jkn6zvri0lr8xciv"))))
(build-system emacs-build-system)
(home-page "https://www.emacswiki.org/emacs/IdleHighlight")
(synopsis "Highlights all occurrences of the word the point is on")