aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 12:43:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:22 +0200
commitf778e76f5d27e005650ff8292aeff069acefd914 (patch)
treed033c21eee3c3fae6dbe44ff8b98e62560c0734d /gnu/packages
parent4c60535bb3a71f51b660a353e98ccfa8e795de92 (diff)
downloadguix-f778e76f5d27e005650ff8292aeff069acefd914.tar.gz
guix-f778e76f5d27e005650ff8292aeff069acefd914.zip
gnu: texlive-was: Refresh package definition.
* gnu/packages/tex.scm (texlive-was): Remove SIMPLE-TEXLIVE-PACKAGE call.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7f2831ff5f..6575669987 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12182,24 +12182,23 @@ possible to register these float types with endfloat.")
(define-public texlive-was
(package
- (inherit (simple-texlive-package
- "texlive-was"
- (list "doc/latex/was/"
- "source/latex/was/"
- "tex/latex/was/")
- (base32
- "1fp0l9sn9yrhf8hz175dzc2x28byk1ygfirn23am5ak72csmi0cp")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/was")
+ (name "texlive-was")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/was/" "source/latex/was/"
+ "tex/latex/was/")
+ (base32
+ "1fp0l9sn9yrhf8hz175dzc2x28byk1ygfirn23am5ak72csmi0cp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/was")
(synopsis "Collection of small packages by Walter Schmidt")
- (description "A bundle of packages that arise in the author’s area of interest:
-
-@itemize
-@item compliance of maths typesetting with ISO standards;
-@item symbols that work in both maths and text modes
-@item commas for both decimal separator and maths; and
-@item upright Greek letters in maths
-@end itemize")
+ (description
+ "This package provides a bundle of packages that arise in the author's
+area of interest: compliance of maths typesetting with ISO standards; symbols
+that work in both maths and text modes commas for both decimal separator and
+maths; and upright Greek letters in maths.")
(license license:lppl1.2+)))
(define-public texlive-xpatch