aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-27 13:19:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-27 13:19:00 +0200
commitf5493629e2650c0d30caf0f01f76b2383f78b9de (patch)
tree46bcbff458edb9741f4f38e21f1e61359eeb026d /gnu/packages
parenta8df11fa6c3cce36c8e2ada72b7f6d03f5a35123 (diff)
downloadguix-f5493629e2650c0d30caf0f01f76b2383f78b9de.tar.gz
guix-f5493629e2650c0d30caf0f01f76b2383f78b9de.zip
gnu: php: Add another test to the skip-test list.
* gnu/packages/php.scm (php)[arguments]: Add a test which fails on multiple architectures to the list skipped by all architectures. Change-Id: I3c55179381ff4cf3e22db5d3ededf60d2a3d9d73
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/php.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 4bfb6e353f..d5e471f8f5 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -195,7 +195,6 @@
"ext/intl/tests/timezone_getErrorCodeMessage_basic.phpt"
"ext/intl/tests/timezone_getOffset_error.phpt"
"sapi/cli/tests/cli_process_title_unix.phpt"
- "sapi/cli/tests/upload_2G.phpt"
"Zend/tests/concat_003.phpt"))
((target-x86-32?)
`(list "ext/dba/tests/dba_gdbm.phpt"))
@@ -209,8 +208,6 @@
"sapi/phpdbg/tests/watch_004.phpt"
"sapi/phpdbg/tests/watch_005.phpt"
"sapi/phpdbg/tests/watch_006.phpt"))
- ((target-riscv64?)
- `(list "sapi/cli/tests/upload_2G.phpt"))
(else `'())))
;; Drop tests that are known to fail.
@@ -276,7 +273,10 @@
"ext/gd/tests/bug73272.phpt"
;; PCRE with/without JIT gives different result
"ext/pcre/tests/gh11374.phpt"
- "ext/pcre/tests/gh11956.phpt"))
+ "ext/pcre/tests/gh11956.phpt"
+
+ ;; This test fails on most architectures.
+ "sapi/cli/tests/upload_2G.phpt"))
;; Accomodate two extra openssl errors flanking the expected one:
;; random number generator:RAND_{load,write}_file:Cannot open file