aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 10:52:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 11:33:07 +0200
commitf5180e24b2ddf5e0f9b5a3a04765fae3f6aa54c4 (patch)
tree4170c3c334a299cd7e17cd457e3a4f4778c6bd06 /gnu/packages
parentfb727d8e3caf4dd1d427a128d2d420fcb043231c (diff)
downloadguix-f5180e24b2ddf5e0f9b5a3a04765fae3f6aa54c4.tar.gz
guix-f5180e24b2ddf5e0f9b5a3a04765fae3f6aa54c4.zip
gnu: Add texlive-ethiop.
* gnu/packages/tex.scm (texlive-ethiop): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bc0a64bab0..18395543de 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11206,6 +11206,36 @@ an @file{.eps} file has anything except the origin for the lower-left of its
bounding box.")
(license license:public-domain)))
+(define-public texlive-ethiop
+ (package
+ (name "texlive-ethiop")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ethiop/"
+ "fonts/ofm/public/ethiop/"
+ "fonts/ovf/public/ethiop/"
+ "fonts/ovp/public/ethiop/"
+ "fonts/source/public/ethiop/"
+ "fonts/tfm/public/ethiop/"
+ "omega/ocp/ethiop/"
+ "omega/otp/ethiop/"
+ "source/latex/ethiop/"
+ "tex/latex/ethiop/")
+ (base32
+ "1852g96rjyrsky7mpfwlxgip11qmk800xcmqccs8cv51f5342qlq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (native-inputs (list texlive-metafont))
+ (home-page "https://ctan.org/pkg/ethiop")
+ (synopsis "LaTeX macros and fonts for typesetting Amharic")
+ (description
+ "This package provides Ethiopian language support for the Babel package,
+including a collection of fonts and TeX macros for typesetting the characters
+of the languages of Ethiopia, with Metafont fonts based on EthTeX's. The
+macros use the Babel framework.")
+ (license license:gpl3+)))
+
(define-public texlive-expex-acro
(package
(name "texlive-expex-acro")