aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 18:53:59 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:07 +0300
commitf445c75d51ace6fea9c2d85a9dc111b6668eb47f (patch)
tree96b0c31c9a677cd7e204efa0754183862ac19040 /gnu/packages
parentf063e18c753459e2ff1da80221a21e2cdba65990 (diff)
downloadguix-f445c75d51ace6fea9c2d85a9dc111b6668eb47f.tar.gz
guix-f445c75d51ace6fea9c2d85a9dc111b6668eb47f.zip
gnu: Add emacs-ewmctrl.
* gnu/packages/emacs.scm (emacs-ewmctrl): New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 211befa75c..74d07d58b4 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8253,3 +8253,27 @@ arXiv, Google Scholar, Library of Congress, etc.
@item Imports BibTeX entries from CrossRef and other sources.
@end itemize\n")
(license license:gpl3+))))
+
+(define-public emacs-ewmctrl
+ (let ((commit "3d0217c4d6cdb5c308b6cb4293574f470d4faacf")
+ (revision "1"))
+ (package
+ (name "emacs-ewmctrl")
+ (version (string-append "0.0.1" "-" revision "."
+ (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/flexibeast/ewmctrl.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0ilwvx0qryv3v6xf0gxqwnfm6pf96gxap8h9g3f6z6lk9ff4n1wi"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/flexibeast/ewmctrl")
+ (synopsis "Emacs interface to @code{wmctrl}")
+ (description "@code{ewmctrl} provides an Emacs interface to
+@code{wmctrl} command-line window-management program.")
+ (license license:gpl3+))))