aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
commitf3a9c30d2d75d3b64184bc5b049f311f33645829 (patch)
treeef812d31ed5a85155aa5e67b9d4de3437e1a8312 /gnu/packages
parentf0a5992ee8acea0a31c4bad05e5c708fb845c0de (diff)
downloadguix-f3a9c30d2d75d3b64184bc5b049f311f33645829.tar.gz
guix-f3a9c30d2d75d3b64184bc5b049f311f33645829.zip
gnu: Expand some substandard imported descriptions.
* gnu/packages/crates-io.scm (rust-fs-set-times-0.19)[description]: Use upstream's blurb, mostly. (rust-jwalk-0.8)[synopsis, description]: Likewise. Change-Id: Ifeac5e37d05bd1075634d060e834e7384873544f
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 89a54b2b5b..15a16a6310 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -27896,8 +27896,10 @@ There are multiple main modules for fsio:
("rust-rustix" ,rust-rustix-0.37)
("rust-windows-sys" ,rust-windows-sys-0.48))))
(home-page "https://github.com/bytecodealliance/fs-set-times")
- (synopsis "Set filesystem timestamps")
- (description "Set filesystem timestamps")
+ (synopsis "Set file system timestamps")
+ (description
+ "This Rust crate provides functions to set timestamps on files,
+directories, and other file system objects.")
(license (list license:asl2.0 license:expat))))
(define-public rust-fs-utils-1
@@ -32410,9 +32412,15 @@ characters in HTML, decoding and unescaping HTML entities as well.")
("rust-walkdir" ,rust-walkdir-2))))
(home-page "https://github.com/byron/jwalk")
(synopsis
- "Filesystem walk performed in parallel with streamed and sorted results")
+ "File system walk performed in parallel with streamed and sorted results")
(description
- "Filesystem walk performed in parallel with streamed and sorted results.")
+ "This Rust crate implements a file system walk that runs in parallel
+using @code{rayon}. It attempts to combine the parallelism of @code{ignore}
+with @code{walkdir}'s streaming iterator API. Entries are streamed in sorted
+order with options for custom sorting, filtering, and skipping.
+
+Directory traversal is already pretty fast. If you don't need this crate's
+speed then walkdir provides a smaller and more tested single threaded implementation.")
(license license:expat)))
(define-public rust-koibumi-base32-0.0.2