aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 14:02:33 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-25 21:12:13 +0800
commitf2b48558dfe033708e02667e24e08cd5c0861aa3 (patch)
treef20a9c6518cd85dec9cee2c5fbb497f0d9eaa705 /gnu/packages
parent35bfe41a015d5d1e92896d8bc995491120032c94 (diff)
downloadguix-f2b48558dfe033708e02667e24e08cd5c0861aa3.tar.gz
guix-f2b48558dfe033708e02667e24e08cd5c0861aa3.zip
gnu: lxqt.scm: Move qttools from inputs to native-inputs.
* gnu/packages/lxqt.scm: Move qttools from inputs to native-inputs. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lxqt.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 39f7b2c3a8..7f2d251a76 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -104,11 +104,11 @@ and import their menus over DBus.")
("menu-cache" ,menu-cache)
("pcre" ,pcre)
("qtbase" ,qtbase)
- ("qttools" ,qttools)
("qtx11extras" ,qtx11extras)))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("lxqt-build-tools" ,lxqt-build-tools)))
+ ("lxqt-build-tools" ,lxqt-build-tools)
+ ("qttools" ,qttools)))
(home-page "https://lxqt.org/")
(synopsis "Qt binding for libfm")
(description "libfm-qt is the Qt port of libfm, a library providing
@@ -147,10 +147,10 @@ components to build desktop file managers which belongs to LXDE.")
("libxscrnsaver" ,libxscrnsaver)
("polkit-qt" ,polkit-qt)
("qtsvg" ,qtsvg)
- ("qttools" ,qttools)
("qtx11extras" ,qtx11extras)))
(native-inputs
- `(("lxqt-build-tools" ,lxqt-build-tools)))
+ `(("lxqt-build-tools" ,lxqt-build-tools)
+ ("qttools" ,qttools)))
(home-page "https://lxqt.org/")
(synopsis "Core utility library for all LXQt components")
(description "liblxqt provides the basic libraries shared by the
@@ -550,12 +550,12 @@ allows for launching applications or shutting down the system.")
("libqtxdg" ,libqtxdg)
("qtbase" ,qtbase)
("qtsvg" ,qtsvg)
- ("qttools" ,qttools)
("qtx11extras" ,qtx11extras)
("xdg-user-dirs" ,xdg-user-dirs)))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("lxqt-build-tools" ,lxqt-build-tools)))
+ ("lxqt-build-tools" ,lxqt-build-tools)
+ ("qttools" ,qttools)))
(arguments
`(#:tests? #f
#:configure-flags
>services: openssh: Replace 'without-password' by 'prohibit-password'....For some time, OpenSSH's option 'PermitRootLogin' has deprecated the ambiguous argument 'without-password' with 'prohibit-password'. * doc/guix.texi (Network Services): Replace 'without-password by 'prohibit-password. * gnu/machine/digital-ocean.scm (guix-infect): Change system configuration to use 'prohibit-password. * gnu/services/ssh.scm (openssh-configuration): Change comment to use 'prohibit-password. (openssh-config-file): Add support for 'prohibit-password to 'permit-root-login'. Warn about deprecated 'without-password usage. * gnu/tests/ganeti.scm (%ganeti-os): Replace 'without-password by 'prohibit-password. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Brice Waegeneire 2021-06-03machine: ssh: Respect calling convention for monadic procedures....Fixes a regression introduced in 2885c3568edec35086f8feeae5b60259cbea407c. Reported by Mathieu Othacehe. * gnu/machine/ssh.scm (deploy-managed-host)[eval/error-handling]: Return two values in the standard case. Ludovic Courtès 2021-06-01machine: ssh: Gracefully handle failure of the effectful bits....Previously, '&inferior-exception' raised by 'upgrade-shepherd-services' and co. would go through as-is, leaving users with an ugly backtrace. * gnu/machine/ssh.scm (deploy-managed-host): Define 'eval/error-handling' and use it in lieu of EVAL as arguments to 'switch-to-system', 'upgrade-shepherd-services', and 'install-bootloader'. Ludovic Courtès 2021-02-25machine: ssh: Use 'formatted-message'....* gnu/machine/ssh.scm (machine-check-initrd-modules): Use 'formatted-message' instead of 'format' + '&message'. Ludovic Courtès 2021-01-04machine: ssh: Do not import the host (guix config), really....This is a followup to 70ffa8af1e93ab8a92c4622745e9cb4a2782f3c8, which did not really solve the problem. * gnu/machine/ssh.scm (not-config?): New procedure. (machine-boot-parameters): Use it as an argument to 'source-module-closure'. Ludovic Courtès 2020-12-21system: Allow separated /boot and encrypted root....* gnu/bootloader/grub.scm (grub-configuration-file): New parameter store-crypto-devices. [crypto-devices]: New helper function. [builder]: Use crypto-devices. * gnu/machine/ssh.scm (roll-back-managed-host): Use boot-parameters-store-crypto-devices to provide its contents to the bootloader configuration generation process. * gnu/tests/install.scm (%encrypted-root-not-boot-os, %encrypted-root-not-boot-os): New os declaration. (%encrypted-root-not-boot-installation-script): New script, whose contents were initially taken from %encrypted-root-installation-script. (%test-encrypted-root-not-boot-os): New test. * gnu/system.scm (define-module): Export operating-system-bootoader-crypto-devices and boot-parameters-store-crypto-devices. (<boot-parameters>): Add field store-crypto-devices. (read-boot-parameters): Parse store-crypto-devices field. [uuid-sexp->uuid]: New helper function extracted from device-sexp->device. (operating-system-bootloader-crypto-devices): New function. (operating-system-bootcfg): Use operating-system-bootloader-crypto-devices to provide its contents to the bootloader configuration generation process. (operating-system-boot-parameters): Add store-crypto-devices to the generated boot-parameters. (operating-system-boot-parameters-file): Likewise to the file with the serialized structure. * guix/scripts/system.scm (reinstall-bootloader): Use boot-parameters-store-crypto-devices to provide its contents to the bootloader configuration generation process. * tests/boot-parameters.scm (%default-store-crypto-devices): New variable. (%grub-boot-parameters, test-read-boot-parameters): Use %default-store-crypto-devices. (tests store-crypto-devices): New tests. Miguel Ángel Arruga Vivas 2020-11-09machine: ssh: Do not import the host (guix config)....* gnu/machine/ssh.scm (machine-boot-parameters): Use 'make-config.scm' for (guix config). Ludovic Courtès 2020-11-01system: Add store-directory-prefix to boot-parameters....Fixes <http://issues.guix.gnu.org/44196> * gnu/machine/ssh.scm (roll-back-managed-host): Use boot-parameters-store-directory-prefix. * gnu/system.scm (define-module): Export boot-parameters-store-directory-prefix. (<boot-parameters>)[store-directory-prefix]: New field. It is used to generate the correct paths when /gnu/store is installed on a btrfs subvolume whose name doesn't match the final runtime path, as the bootloader doesn't have knowledge about the final mounting points. [boot-parameters-store-directory-prefix]: New accessor. (read-boot-parameters): Read directory-prefix from store field. (operating-system-boot-parameters-file): Add directory-prefix to store field. * guix/scripts/system.scm (reinstall-bootloader): Use boot-parameters-store-directory-prefix. * test/boot-parameters.scm (%default-btrfs-subvolume, %default-store-directory-prefix): New variables. (%grub-boot-parameters): Use %default-store-directory-prefix. (%default-operating-system): Use %default-btrfs-subvolume. (test-boot-parameters): Add directory-prefix. (test optional fields): Add test for directory-prefix. (test os store-directory-prefix): New test. Miguel Ángel Arruga Vivas 2020-10-18system: Provide locale information to the bootloader....* gnu/machine/ssh.scm (roll-back-managed-host): Use locale information from boot-parameters. * gnu/system.scm (operating-system-bootcfg): Provide locale information to the bootloader. * guix/system/script.scm (reinstall-bootloader): Use locale information from boot-parameters. Miguel Ángel Arruga Vivas