aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:08:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:42 +0200
commitee5d8bf5e0908a143b3a034cc9694694da1a3c4e (patch)
treebeafb1e140ab749a3fd9f873db3058286e6c4982 /gnu/packages
parent9acb757ea64e8d0b235a9a60aa08574ce1536234 (diff)
downloadguix-ee5d8bf5e0908a143b3a034cc9694694da1a3c4e.tar.gz
guix-ee5d8bf5e0908a143b3a034cc9694694da1a3c4e.zip
gnu: Add texlive-kdpcover.
* gnu/packages/tex.scm (texlive-kdpcover): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b729e5b02e..9696f79cae 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -18183,6 +18183,40 @@ for writing course texts, and @code{kdgmasterthesis} for writing master's
theses.")
(license license:lppl1.3+)))
+(define-public texlive-kdpcover
+ (package
+ (name "texlive-kdpcover")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/kdpcover/"
+ "source/latex/kdpcover/"
+ "tex/latex/kdpcover/")
+ (base32
+ "116pzg0bdrj78vs2sq196jcwnv16b734kqnhfcg3fka4mf6jk2d1")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-anyfontsize
+ texlive-geometry
+ texlive-graphics
+ texlive-microtype
+ texlive-pgf
+ texlive-setspace
+ texlive-textpos
+ texlive-tools
+ texlive-xcolor
+ texlive-xifthen
+ texlive-xkeyval))
+ (home-page "https://ctan.org/pkg/kdpcover")
+ (synopsis "Covers for books published by Kindle Direct Publishing")
+ (description
+ "The problem this class solves is the necessity to change the size of the
+cover PDF according to the number of pages in the book --- the bigger the
+book, the larger the spine of the book must be. The provided class makes the
+necessary calculations on-the-fly, using the @code{qpdf} tool.")
+ (license license:expat)))
+
(define-public texlive-kixfont
(package
(name "texlive-kixfont")