aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
'commit-subject'>gnu: Add python-relatorio.
* gnu/packages/python.scm (python-relatorio, python2-relatorio): New variables. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages')
authorAdriano Peluso <catonano@gmail.com>2017-05-20 09:19:00 +0200
committerArun Isaac <arunisaac@systemreboot.net>2017-05-27 18:41:12 +0530
commit2023-07-09gnu: wimlib: Update to 1.14.1....Tobias Geerinckx-Rice
2023-07-09gnu: rdiff-backup: Update to 2.2.5....Tobias Geerinckx-Rice
2023-07-09gnu: snapraid: Update to 12.2....Tobias Geerinckx-Rice
2023-07-09gnu: borg: Update to 1.2.4....Tobias Geerinckx-Rice
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 23a96a25e5..ad042e34e1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14865,3 +14865,28 @@ textual content for output generation on the web.")
;; the "python-genshi-" prefix instead of "python2-genshi-".
(define-public python2-genshi
(package-with-python2 python-genshi))
+
+(define-public python-relatorio
+ (package
+ (name "python-relatorio")
+ (version "0.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "relatorio" version))
+ (sha256
+ (base32
+ "0lincq79mzgazwd9gh41dybjh9c3n87r83pl8nk3j79aihyfk84z"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-lxml" ,python-lxml)
+ ("python-genshi" ,python-genshi)))
+ (home-page "https://relatorio.tryton.org/")
+ (synopsis "Templating library able to output ODT and PDF files")
+ (description "Relatorio is a templating library which provides a way to
+easily output ODT, ODS, PNG, SVG and several other kinds of files. Support
+for more filetypes can be easily added by creating plugins for them.")
+ (license license:gpl3+)))
+
+(define-public python2-relatorio
+ (package-with-python2 python-relatorio))