aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-31 00:30:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-31 04:06:08 +0200
commitec23833267ac859d3d45f65603e55415475126ba (patch)
tree125ff01e00112ffb1711857699ec7be163028f0d /gnu/packages
parent02052b2c9b37af399f36179a8341585b30976650 (diff)
downloadguix-ec23833267ac859d3d45f65603e55415475126ba.tar.gz
guix-ec23833267ac859d3d45f65603e55415475126ba.zip
gnu: hdparm: Use ‘modify-phases’ syntax.
* gnu/packages/linux.scm (hdparm): Use ‘modify-phases’.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7a9ecf0a00..f801146cd6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2283,8 +2283,10 @@ thanks to the use of namespaces.")
(list (string-append "binprefix=" out)
(string-append "manprefix=" out)
"CC=gcc"))
- #:phases (alist-delete 'configure %standard-phases)
- #:tests? #f)) ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)) ; no configure script
+ #:tests? #f)) ; no test suite
(home-page "https://sourceforge.net/projects/hdparm/")
(synopsis "View and tune ATA disk drive parameters")
(description
tr>2020-02-15gnu: bison: Update to 3.5.2.Marius Bakke 2020-01-24gnu: bison: Update to 3.5.1....* gnu/packages/bison.scm (bison): Update to 3.5.1. Marius Bakke 2019-12-16gnu: bison: Update to 3.5....* gnu/packages/bison.scm (bison): Update to 3.5. Efraim Flashner 2019-11-26gnu: bison: Update to 3.4.2....* gnu/packages/bison.scm (bison): Update to 3.4.2. Efraim Flashner 2019-09-30gnu: xyce: Use Bison 3.0....Xyce requires Bison 3.0 at the latest. * gnu/packages/bison.scm (bison-3.0): New variable. * gnu/packages/engineering.scm (xyce-serial)[native-inputs]: Use BISON-3.0 instead of BISON. Ludovic Courtès 2019-06-17gnu: bison: Disable parallel tests, too....* gnu/packages/bison.scm (bison)[arguments]: Add #:parallel-tests?. Marius Bakke 2019-06-16gnu: bison: Disable parallel build....Fixes <https://bugs.gnu.org/36238. Reported by Carl Dong <contact@carldong.me>. * gnu/packages/bison.scm (bison)[arguments]: New field. Marius Bakke 2019-05-25gnu: bison: Update to 3.4.1....* gnu/packages/bison.scm (bison): Update to 3.4.1. Marius Bakke