aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-01-09 04:38:41 +0000
committerLudovic Courtès <ludo@gnu.org>2022-01-25 23:54:45 +0100
commitebac201995aa663716e0aeb7ddd9e2af24b09770 (patch)
treecddeaddb42ed4132a7cb1e2b1c14cd117db48002 /gnu/packages
parent5e51ccc120871502609de10f21b897af33594a65 (diff)
downloadguix-ebac201995aa663716e0aeb7ddd9e2af24b09770.tar.gz
guix-ebac201995aa663716e0aeb7ddd9e2af24b09770.zip
gnu: Add python-regions.
* gnu/packages/astronomy.scm (python-regions): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/astronomy.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 20961e1436..e968fd2480 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -857,6 +857,45 @@ of astronomical sources.")
Virtual observatory (VO) using Python.")
(license license:bsd-3)))
+(define-public python-regions
+ (package
+ (name "python-regions")
+ (version "0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "regions" version))
+ (sha256
+ (base32 "1bjrcjchbw3xw1a26d5g198lh7vxpp9m5sal58r7f8mmr1d8g2dc"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "pytest"
+ #:phases
+ (modify-phases %standard-phases
+ ;; This doctest requires online data.
+ (add-after 'unpack 'delete-doctest
+ (lambda _ (delete-file "docs/masks.rst")))
+ ;; This file is opened in both install and check phases.
+ (add-before 'install 'writable-compiler
+ (lambda _ (make-file-writable "regions/_compiler.c")))
+ (add-before 'check 'writable-compiler
+ (lambda _ (make-file-writable "regions/_compiler.c")))
+ (add-before 'check 'writable-home
+ (lambda _ (setenv "HOME" (getcwd)))))))
+ (propagated-inputs
+ (list python-astropy python-numpy))
+ (native-inputs
+ (list python-cython
+ python-extension-helpers
+ python-pytest-arraydiff
+ python-pytest-astropy
+ python-pytest-runner
+ python-setuptools-scm))
+ (home-page "https://github.com/astropy/regions")
+ (synopsis "Package for region handling")
+ (description "Regions is an Astropy package for region handling.")
+ (license license:bsd-3)))
+
(define-public python-astral
(package
(name "python-astral")
19-08-07 18:29:07 -0400'>2019-08-07machine: Add 'build-locally?' field for managed hosts....* gnu/machine/ssh.scm (machine-ssh-configuration-build-locally?): New variable. (managed-host-remote-eval): Pass 'build-locally?' to 'remote-eval'. Jakob L. Kreuze 2019-08-06machine: Implement safety checks....* gnu/machine/ssh.scm (machine-check-file-system-availability) (machine-check-initrd-modules, check-deployment-sanity): New variable. (deploy-managed-host): Perform safety checks before deploying. Jakob L. Kreuze 2019-08-06machine: Rename 'system' field....* gnu/machine.scm (machine-system): Delete variable. (machine-operating-system): New variable. All callers changed. * doc/guix.texi (Invoking guix deploy): Use the 'machine-operating-system' accessor rather than 'machine-system'. Jakob L. Kreuze 2019-07-26guix system: Add 'reconfigure' module....* guix/scripts/system/reconfigure.scm: New file. * Makefile.am (MODULES): Add it. * guix/scripts/system.scm (bootloader-installer-script): Export variable. * gnu/machine/ssh.scm (switch-to-system, upgrade-shepherd-services) (install-bootloader): Delete variable. * gnu/machine/ssh.scm (deploy-managed-host): Rewrite procedure. * gnu/services/herd.scm (live-service): Export variable. * gnu/services/herd.scm (live-service-canonical-name): New variable. * tests/services.scm (live-service): Delete variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Jakob L. Kreuze 2019-07-18machine: Fix typo....* gnu/machine/ssh.scm (managed-host-environment-type)[description]: Fix typo. Tobias Geerinckx-Rice 2019-07-06gnu: Add machine type for deployment specifications....* gnu/machine.scm: New file. * gnu/machine/ssh.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Jakob L. Kreuze