aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:15:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:32 +0200
commite9a9491a07ec2cf111f73105bad49a494c4a74b2 (patch)
tree5884e2cbcc7f62764e2696a5349eb0202f3a1e5d /gnu/packages
parentda5e05d8ecfd6ebb1fe2e507030218037f307877 (diff)
downloadguix-e9a9491a07ec2cf111f73105bad49a494c4a74b2.tar.gz
guix-e9a9491a07ec2cf111f73105bad49a494c4a74b2.zip
gnu: Add texlive-pgf-umlcd.
* gnu/packages/tex.scm (texlive-pgf-umlcd): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 66e6d99b9f..30c21aa296 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3122,6 +3122,25 @@ elements and their ions (from the NASA database and from NIST). It also
allows the user to draw spectra using their own data.")
(license license:lppl1.3+)))
+(define-public texlive-pgf-umlcd
+ (package
+ (name "texlive-pgf-umlcd")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pgf-umlcd/"
+ "tex/latex/pgf-umlcd/")
+ (base32
+ "14zx2jms616qfzwqbgixz0pd3qzjzr2bxr6ahhy7mgj3i7rlbr8r")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-latex texlive-pgf))
+ (home-page "https://ctan.org/pkg/pgf-umlcd")
+ (synopsis "Some LaTeX macros for UML class diagrams")
+ (description
+ "This package provides some LaTeX macros for UML class diagrams.")
+ (license (list license:gpl2 license:lppl1.3c))))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")