aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-10-01 08:58:10 -0500
committerjgart <jgart@dismail.de>2024-10-01 10:02:35 -0500
commite92516d900927bf8efceecc161c78f03785ded71 (patch)
tree0b4bd8381e4c5d280d0316569371628edd5882a5 /gnu/packages
parent6da2deff73413d3809b529b5cf093af30dc0d208 (diff)
downloadguix-e92516d900927bf8efceecc161c78f03785ded71.tar.gz
guix-e92516d900927bf8efceecc161c78f03785ded71.zip
gnu: Add lem.
* gnu/packages/text-editors.scm (lem): New variable. Co-authored-by: Ada Stevenson <adanskana@gmail.com> Change-Id: I2946355068597e44b8699281647bcd8d98f47911
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/text-editors.scm87
1 files changed, 86 insertions, 1 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 3435ad5b18..afc6caffbe 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -25,7 +25,7 @@
;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
-;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022, 2024 jgart <jgart@dismail.de>
;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2023 Eidvilas Markevičius <markeviciuseidvilas@gmail.com>
@@ -55,6 +55,7 @@
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix utils)
+ #:use-module (guix build-system asdf)
#:use-module (guix build-system cargo)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
@@ -92,6 +93,8 @@
#:use-module (gnu packages image)
#:use-module (gnu packages lesstif)
#:use-module (gnu packages libbsd)
+ #:use-module (gnu packages lisp-check)
+ #:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages llvm)
#:use-module (gnu packages lua)
#:use-module (gnu packages ncurses)
@@ -144,6 +147,88 @@ complex tasks to be performed in an automated way. GNU ed offers several
extensions over the standard utility.")
(license license:gpl3+)))
+(define-public lem
+ (let ((commit "3f2f0adb6db2dbed57b5cccca34f47ab9d5a2314")
+ (revision "0"))
+ (package
+ (name "lem")
+ (version (git-version "2.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lem-project/lem/")
+ (commit commit)))
+ (sha256
+ (base32 "00b4wn75ssywrhr4b7h4vk7hyd6dac2618339k56vg9vwni1bbxi"))
+ (file-name (git-file-name name version))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ (delete-file-recursively "roswell")))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'create-asdf-configuration 'build-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (build-program
+ (string-append (assoc-ref outputs "out") "/bin/lem")
+ outputs
+ #:dependencies '("lem-ncurses" "lem-sdl2")
+ #:entry-program '((lem:main) 0)))))))
+ (native-inputs
+ (list sbcl-cl-ansi-text
+ sbcl-rove
+ sbcl-trivial-package-local-nicknames))
+ (inputs
+ (list
+ sbcl-alexandria
+ sbcl-trivia
+ sbcl-trivial-gray-streams
+ sbcl-trivial-types
+ sbcl-cl-ppcre
+ sbcl-closer-mop
+ sbcl-iterate
+ sbcl-lem-mailbox
+ sbcl-inquisitor
+ sbcl-babel
+ sbcl-bordeaux-threads
+ sbcl-yason
+ sbcl-log4cl
+ sbcl-split-sequence
+ sbcl-cl-str
+ sbcl-dexador
+ sbcl-3bmd
+ sbcl-micros
+ sbcl-lisp-preprocessor
+ sbcl-trivial-ws
+ sbcl-trivial-open-browser
+ sbcl-sdl2
+ sbcl-sdl2-ttf
+ sbcl-sdl2-image
+ sbcl-trivial-main-thread
+ sbcl-cffi
+ sbcl-cl-charms
+ sbcl-cl-setlocale
+ sbcl-log4cl
+ sbcl-jsonrpc
+ sbcl-usocket
+ sbcl-quri
+ sbcl-cl-change-case
+ sbcl-async-process
+ sbcl-cl-iconv
+ sbcl-esrap
+ sbcl-parse-number
+ sbcl-cl-package-locks
+ sbcl-slime-swank
+ sbcl-trivial-utf-8))
+ (home-page "http://lem-project.github.io/")
+ (synopsis "Integrated IDE/editor for Common Lisp")
+ (description "Lem is a Common Lisp editor/IDE with high expansibility.")
+ (license license:expat))))
+
(define-public vis
(package
(name "vis")
Ludovic Courtès 2023-12-31doc: cookbook: Fix typo....Follow-up: f24b14767d362a84e6469682b4fe303b50f4b589 * doc/guix-cookbook.texi (Routed network for libvirt): Fix typo in section name. Change-Id: I1ba7ee2cba89764283f6a702a793ee9100585a87 Jonathan Brielmaier 2023-12-30Add network bridge guide to the cookbook....Change-Id: If478196985aac7947067329957516f82bcb95ca4 Maxim Cournoyer 2023-12-18Update cookbook Texinfo menus....Automated via C-c C-u C-a with Emacs. Change-Id: I9e595430529f8f994988c1ac3c919bdaef930dc1 Maxim Cournoyer 2023-10-25doc: cookbook: Fix a broken cross-reference....* doc/guix-cookbook.texi (Building with Guix): Adjust xref target. Change-Id: I87d6dc2648ff8898e3dd3b5ffca748193f14751e Florian Pelz 2023-10-24doc: cookbook: Add cross references to the manual regarding manifests....* doc/guix-cookbook.texi (The benefits of manifests) (Reproducible profiles): Add cross-references. Ludovic Courtès 2023-10-24doc: cookbook: Suggest ‘guix shell’ as an alternative to multiple profiles....Multiple profiles are relatively hard to set up and maintain, especially for newcomers. Thus, suggest ‘guix shell’ as an alternative. * doc/guix-cookbook.texi (Guix Profiles in Practice): Add note linking to ‘guix shell’. (The benefits of manifests): Remove outdated info about ‘guix environment’ and profiles that may be GC’d. Update. Ludovic Courtès 2023-10-11doc: cookbook: Add “Software Development” chapter....* doc/guix-cookbook.texi (Software Development): New chapter. Ludovic Courtès 2023-09-01cookbook: Add a recipe for running Guix System on a Kimsufi server....* doc/guix-cookbook.texi (Running Guix on a Kimsufi Server): New section. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Thomas Ieong 2023-09-01doc: cookbook: Document the configuration of a Yubikey with KeePassXC....* doc/guix-cookbook.texi (Using security keys) [Requiring a Yubikey to open a KeePassXC database]: New subsection. Series-to: 65354@debbugs.gnu.org Maxim Cournoyer 2023-08-25image: Add mbr-raw-image-type and use by default....* gnu/system/image.scm (mbr-disk-image, mbr-raw-image-type): New variables. (qcow2-image-type): Inherit mbr-disk-image. * guix/scripts/system.scm (%default-options): Use mbr-raw-image-type by default. * gnu/tests/install.scm (run-install): Use mbr-raw in the tests. * doc/guix-cookbook.texi (Guix System Image API): Update the list of image types. * doc/guix.texi (Invoking guix system, System Images, image-type Reference): Add mbr-raw and switch documented default to it. Josselin Poiret 2023-08-17doc: cookbook: Document how to disable the Yubikey OTP application....* doc/guix-cookbook.texi (Using security keys) <Disabling OTP code generation for a Yubikey>: New subsection. Reviewed-by: John Kehayias <john.kehayias@protonmail.com> Maxim Cournoyer 2023-08-16doc: cookbook: Document a dynamic DNS update mcron job....* doc/guix-cookbook.texi (System Configuration) <Dynamic DNS mcron job>: New subsection. Reviewed-by: Ludovic Courtès <ludo@gnu.org> Maxim Cournoyer 2023-08-16doc: Update Cookbook Texinfo menus....Automated via C-c C-u C-a (M-x texinfo-all-menus-update) in Emacs. Maxim Cournoyer