aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorvicvbcun <guix@ikherbers.com>2022-07-23 22:51:58 +0200
committerAndreas Enge <andreas@enge.fr>2025-01-20 11:55:49 +0100
commite8956056012fb6b5cb1a00be502a8ec8a414e362 (patch)
tree6d1559a3a1b16aa77cd4a287190831e578025e0f /gnu/packages
parentcb6a9bd81fdec46894b0ea01501cba99e4e26a3f (diff)
downloadguix-e8956056012fb6b5cb1a00be502a8ec8a414e362.tar.gz
guix-e8956056012fb6b5cb1a00be502a8ec8a414e362.zip
gnu: cliquer: Update to 1.22.
Switch to an autotoolized fork. * gnu/packages/sagemath.scm (cliquer): Update to 1.22. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/sagemath.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index bc1446327b..f4142b37bf 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -110,19 +110,18 @@ modular forms.")
(define-public cliquer
(package
(name "cliquer")
- (version "1.21")
- ;; The original source package is available from the home page and
- ;; has not seen any release since 2010; it comes with only a Makefile
- ;; without an "install" target. Instead, there is an autotoolized
- ;; tarball available from the Sage project.
- (source
- (origin
- (method url-fetch)
- (uri "http://users.ox.ac.uk/~coml0531/sage/cliquer-1.21.tar.gz")
- (sha256
- (base32
- "1hdzrmrx0nvvj8kbwxrs8swqgkd284khzl623jizixcv28xb77aq"))))
+ (version "1.22")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dimpase/autocliquer")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00gcmrhi2fjn8b246w5a3b0pl7p6haxy5wjvd9kcqib1xanz59z4"))))
(build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool))
(synopsis "C routines for finding cliques in weighted graphs")
(description "Cliquer is a set of reentrant C routines for finding
cliques in a weighted or unweighted graph. It uses an exact
@@ -131,7 +130,7 @@ cliques or cliques with size or weight within a given range, restrict the
search to maximal cliques, store cliques in memory and call a user-defined
function for every found clique.")
(license license:gpl2+)
- (home-page "https://users.aalto.fi/~pat/cliquer.html")))
+ (home-page "https://github.com/dimpase/autocliquer")))
(define-public libbraiding
(package