aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-03-05 12:54:49 -0800
committerLeo Famulari <leo@famulari.name>2023-03-28 16:26:08 -0400
commite7a1ae9bf9a589d74931c5869e85f8dc3ac2c794 (patch)
tree32f7e5ab1f0637177c72d26390c555a8fa834166 /gnu/packages
parentbd89aed9367fd8a4541a6905f0d8403dca73277d (diff)
downloadguix-e7a1ae9bf9a589d74931c5869e85f8dc3ac2c794.tar.gz
guix-e7a1ae9bf9a589d74931c5869e85f8dc3ac2c794.zip
gnu: Add go-github-com-jacobsa-oglematchers.
* gnu/packages/golang.scm (go-github-com-jacobsa-oglematchers): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index dc46c96080..2eb3a67fc5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1217,6 +1217,34 @@ networks where it would otherwise be blocked or heavily throttled.")
not included in the Go standard library.")
(license license:asl2.0))))
+(define-public go-github-com-jacobsa-oglematchers
+ (let ((commit "141901ea67cd4769c6800aa7bfdfc558fa22bda5")
+ (revision "0"))
+ (package
+ (name "go-github-com-jacobsa-oglematchers")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jacobsa/oglematchers")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09ff5x6vbhd9zl1z4yzyk573ifh16rry38q1rx986kbz4hqkmniq"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jacobsa/oglematchers"
+ ;; break loop with with go-github-com-jacobsa-ogletest
+ #:tests? #f))
+ (home-page "https://github.com/jacobsa/oglematchers")
+ (synopsis "Matchers for Go testing framework")
+ (description
+ "Package oglematchers provides a set of matchers useful in a testing or mocking
+framework. These matchers are inspired by and mostly compatible with Google
+Test for C++ and Google JS Test.")
+ (license license:asl2.0))))
+
(define-public go-github-com-kataras-golog
(package
(name "go-github-com-kataras-golog")