aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2015-06-13 08:06:12 -0400
committerDavid Thompson <davet@gnu.org>2015-06-15 20:27:38 -0400
commite778a54950e8ba7c16e638289cae97e1e1975ea4 (patch)
treec93550420e01af4968d0a096f63c4d2c594d94e8 /gnu/packages
parent71d3e2c28de72fe4de5df36a5df19a79cfe0d9d7 (diff)
downloadguix-e778a54950e8ba7c16e638289cae97e1e1975ea4.tar.gz
guix-e778a54950e8ba7c16e638289cae97e1e1975ea4.zip
gnu: Add ruby-multipart-post.
* gnu/packages/ruby.scm (ruby-multipart-post): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 45175df170..ff30c4988a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -642,3 +642,25 @@ and manipulate Git repositories by wrapping system calls to the git binary.")
options and parsing command line flags.")
(home-page "https://github.com/leejarvis/slop")
(license license:expat)))
+
+(define-public ruby-multipart-post
+ (package
+ (name "ruby-multipart-post")
+ (version "2.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/nicksieger/multipart-post/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03n271i3knfx4j9aingxzz2bajd379dw9nswsllviqc177lq1anm"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (synopsis "Multipart POST library for Ruby")
+ (description "Multipart-Post Adds multipart POST capability to Ruby's
+net/http library.")
+ (home-page "https://github.com/nicksieger/multipart-post")
+ (license license:expat)))