aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-09 20:17:07 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-09 20:19:18 +0000
commite6e4e88f4531cc473b3c221f0bf53539319c8e9d (patch)
tree60c4e9f8ffa2d70a6f72d43e78437a8a34391075 /gnu/packages
parentec1a67d4ff7435fdf50de35c3f57d2f60a9cccf9 (diff)
downloadguix-e6e4e88f4531cc473b3c221f0bf53539319c8e9d.tar.gz
guix-e6e4e88f4531cc473b3c221f0bf53539319c8e9d.zip
gnu: webssh: Update to 1.6.2.
* gnu/packages/ssh.scm (webssh): Update to 1.6.2. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. Change-Id: Icaef06a86ac8c4c02a74a376d0501152675d2122
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ssh.scm33
1 files changed, 19 insertions, 14 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 9b42bdc937..054a4cc721 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -938,23 +938,28 @@ clients at a time.")
(define-public webssh
(package
(name "webssh")
- (version "1.5.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/huashengdun/webssh")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1bcy9flrzbvams5p77swwiygv54ac58ia7hpic1bvg30b3wpvv7b"))))
- (build-system python-build-system)
+ (version "1.6.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/huashengdun/webssh")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0v0dxnqac9xdj06lhljv6bhi8hd16rn6h0qr7fkm640nvr55a8i1"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
- (list python-paramiko python-tornado))
+ (list python-paramiko
+ python-tornado))
(home-page "https://webssh.huashengdun.org/")
(synopsis "Web application to be used as an SSH client")
- (description "This package provides a web application to be used as an SSH
-client.
+ (description
+ "This package provides a web application to be used as an SSH client.
Features:
@itemize @bullet